FAQ Database Discussion Community


Modify open cart controller without losing it after an upgrade?

php,opencart,upgrade
I'm new to opencart and I had to modify a controller in order to show a list of featured products on the site's header. The change was very easy, however I think I have to worry about losing the controller's modification if I update open cart. My question is, what's...

.menu() is not a function; jQuery upgrade

javascript,jquery,migration,upgrade
I am migrating a menu widget from jQuery 1.6.4 to a newer version of jQuery , 1.11.1 $(document).ready(function () { $('#takeMeToLink').menu({ content: $('#globalContent1').html(), flyOut: false }); }); Markup <a id="takeMeToLink" href="#" style="color:black"> Take Me To <span style="height:3px;width:15px;position:relative;display:inline-block;overflow:hidden;" class="s4-clust ms-viewselector-arrow"> <img src="/_layouts/15/images/fgimg.png" alt="Open Menu" style="border-width:0px;position:absolute;left:-0px...

How to get rid off unused dll's in wix when upgrade is uninstalled

wix,upgrade
I have a code that has some changes from the previous version. During changes, some dll's were removed. I am using wix to create installer. So now, when I upgrade from old version to new version and when I uninstall the product, inside the product folder, I see those old...

Upgrade H2 from sonarqube 4.5.1 to 5.1.1

sonarqube,upgrade,h2
Today I have installed Sonarqube 5.1.1. Not having a lot of data/projects I'm using the H2 db embedded in Sonarqube. Following the steps in the Upgrading page of the Sonarqube documentation I have the process up and running but without any data. Copying the \data\es folder from the old installation...

Upgrading from 4.0.2 to 4.2.0 breaks paper_trail code

ruby-on-rails,upgrade,papertrail
I am getting the following error in 4.2.0 which works in 4.0.2: undefined method `reverse!' for # in the following line of code: def show @client = Client.find(params[:id]) @versions = @client.versions.reverse! <-- error line end typing in @client.versions.class yields the following: >> @client.versions.class => PaperTrail::Version::ActiveRecord_Associations_CollectionProxy >> Any idea anyone? Thanks....

Spring upgrade on-start equivalent

spring,upgrade,spring-webflow
I am trying to use Spring Webflow 2.3.2. I have a legacy web flow similar to: <start-state id-ref="A" /> <action-state id="A"> <action bean="B" /> <transition on="success" to="T" /> </action-state> <action-state id="T"> ... </action-state> The equivalent code that I am writing for Spring Webflow 2.3.2 is: <on-start> <evaluate expression="B" /> </on-start>...

SocketIO emit with callback fails while upgrading 0.9.16 to 1.3.5

javascript,node.js,socket.io,upgrade
In 0.9.16, I use socket.emit with callback so that the chat server return some data and I can handle the result as per the acknowledgement. But after the upgrade to 1.3.5 I've found a error in console like this Uncaught TypeError: Cannot read property 'apply' of undefined. I've done something...

Upgrading to Visual Studio 2013 from Visual Studio 2005

visual-studio-2013,visual-studio-2005,upgrade
Is it possible to upgrade directly a VS 2005 solution to VS 2013? MSDN mentions VS 2010 and VS 2012 in some articles about upgrading, but it doesn't mention VS 2005. We don't have at the moment VS 2013 but our client is interested in upgrading the project.

Production MobileFirst 7 Server upgrade from Worklight 6.2, Adapter call not working

upgrade,mobilefirst,mobilefirst-adapters
We have a MobileFirst application that worked with Worklight 6.2 server - production also. We are using a http adapter: <connectionPolicy xsi:type="http:HTTPConnectionPolicyType"> Currently we are changing the production server to 7.0.0. On Development Server we could test our application and all the functionalities were OK. We'we created the .war with...

Upgrading a paid app to free app

ios,objective-c,iphone,app-store,upgrade
I have a paid app(version 1.3) on app store. I want to release update(version 1.4) which has in app purchases. I am planning to release the update(version 1.4) which will be free . I have covered all the possible scenarios for the upgrade of user from paid to free version...

How to initiate the call onUpgrade(SQLiteDatabase db, int oldVersion, int newVersion)?

android,upgrade,sqliteopenhelper
I need to upgrade my android sqlite database from version 1 to version 2. But I do not understand how the call public void onUpgrade(SQLiteDatabase db, int oldVersion, int newVersion)is initiated? How and when will this method be called? I don't understand where I pass the Version number 2? [EDIT]...

Linux glibc versions 2.18 and older - vulnerability [closed]

linux,security,upgrade,patch,glibc
Server: Red Hat Enterprise Linux Server release 5.9 (Tikanga) I came to know that Linux GNU C Library (glibc) versions prior to 2.18 are vulnerable to remote code execution via a vulnerability in the gethostbyname function. Exploitation of this vulnerability may allow a remote attacker to take control of an...

Jasmine 1.3 to Jasmine 2.x cheat sheet

jasmine,upgrade,karma-jasmine,major-upgrade,jasmine2.0
I am migrating some unit tests from Jasmine 1.3 to 2.x and I was hoping there was a quick reference cheat sheet for some of the simple commands. Since I have not found one I thought it would be helpful to post what I have so far and others can...

Upgrading Laravel 4.2 to 5.0, getting [ReflectionException] Class App\Http\Controllers\PagesController does not exist

exception,laravel-5,upgrade
I was updating my project from laravel 4.2 to laravel 5.0. But, after I am facing this error and have been trying to solve it for the past 4 hours. I didn't face any error like this on the 4.2 version. I have tried composer dump-autoload with no effect. As...

WiX MSI upgrade disallows installation of some components

xml,wix,windows-installer,installer,upgrade
When I try to do an upgrade of my project, I get the following logs for about eight or so components: MSI (c) (24:EC) [11:50:17:422]: Disallowing installation of component: {290E89A8-6BA7-59F2-B350-BE657C2823BC} since the same component with higher versioned keyfile exists The uninstall portion of the upgrade seems to remove all of...

Upgrade jQuery version from 1.7.1 to 1.11.2

jquery,upgrade
With my current application, I am using jQuery version 1.7.1. Now, I am planning to upgrade the jQuery version to 1.11.2. Is there any patch available to provide the backward comparability to the existing application. Thanks,...

after PHP upgrade - Cannot use object of type stdClass as array

php,arrays,upgrade
After PHP Upgrade I get this Error, on many points: [Wed Jun 10 22:50:16 2015] [error] [client 10.0.7.85] PHP Fatal error: Cannot use object of type stdClass as array in /var/www/bp/apps/frontend/modules/timekeeping/actions/actions.class.php on line 1275, referer: http://10.0.0.244/timekeeping/overviewAbsent if (isset($employee_hours[$this->selected_day - 1]->special) && in_array($employee_hours[$this->selected_day - 1]->special, array( 'u', 'm', 's', 'b', 'kk',...

Upgrading from Laravel 4.2 to Laravel 5

php,laravel,laravel-4,upgrade,laravel-5
I made a website and I spend about 2 month on it, I made it by Laravel 4.2 and now I see the new version of Laravel released (Version 5). My Questions: Should I change and work with Laravel 5? What happens if I don't change to Laravel 5? Does...

WordPress - overwrite core function even after theme or site update

php,wordpress,function,upgrade,overwrite
I have googled this, of course, but I require a solution that stays put even after I upgrade a theme AND/OR upgrade the entire WordPress site to a newer version. Basically, before a post is shown, I want to show specific HTML. And I want it absolutely foolproof because I...

Can't connect jdbc with mysql 5.6

mysql,jdbc,upgrade
When trying to connect from MyBatis and jdbc to mysql 5.6 I get an exception com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: communications link failure This only happened after upgrading from 5.1 to 5.6. I looked at the driver official page. the latest available driver is for 5.1. ...

MarkLogic 8 - Rest Endpoint Returning XML even though we specify JSON

json,xml,rest,upgrade,marklogic
http://localhost/v1/documents?format=json&uri=%2Fdocs%2F1234.json It looks like this URL is giving us XML instead of JSON which is causing some issues. I believe this started happening once we upgraded to Marklogic 8. You can see we are specifying json which seems right based on this: https://docs.marklogic.com/REST/GET/v1/documents How do I get this to return...

Exception after upgrading to Android Studio 141.1972460

android,android-studio,upgrade
I upgraded my Android Studio yesterday to the latest version 141.1972460. After the upgrade, I used my old project configurations. Ever since, I have been trying to clean and rebuild my projects in the upgraded version but I keep getting the following error: Execution failed for task ':app:compileDebugAidl'. > Executor...

Upgrade to Quartz 2.2 JDBC Jobstore new Column Sched_time

java,jdbc,quartz-scheduler,upgrade
I am currently upgrading Quartz to version 2.2. Therefore I had to do some migrations on the Tables which are used by the JDBCJobstore. For the table "qrtz_fired_triggers" there was added the column "sched_time" with a Not Null constraint. Actually I now ran into the issue, that there is an...

Upgrade and add new features with MST transform

c#,upgrade,advanced-installer,orca,missing-features
I am trying to update my application and while doing so also enabling some new features. The features existed in the previous version as well, they were just turned off. I create an MST file using Orca where I have set INSTALLEVEL to 4 and all the features that I...

What could go wrong or why could software stop working if the system where the software is running is updated to a faster system?

upgrade,computer-architecture
I faced this question in interview. I could think of the following reasons: Architecture dependent code may break while moving from say 32 bit to 64 bit machine Some set of instructions may be upgraded to somehow break existing ones (but have feeling that processor architectures are backward compatible to...

Upgrading django 1.6 to 1.7. Is there any change in Generic relations for “related_name”?

python,django,upgrade
I'm trying to upgrade a project from Django 1.6 to 1.7. When I try to run the server I get "TypeError: init() got an unexpected keyword argument 'related_name'": $ ./manage.py runserver --settings=bertondealer.settings.local 0.0.0.0:8000 Traceback (most recent call last): File "./manage.py", line 10, in <module> execute_from_command_line(sys.argv) File "/home/vagrant/.virtualenvs/dealer17/local/lib/python2.7/site-packages/django/core/management/__init__.py", line 385, in...

Upgrade/Convert AJAX.NET controls in a web site converted to Visual Studio 2013 from VS 2005

.net,visual-studio-2013,asp.net-ajax,upgrade
Our client wants to upgrade an existing web application that uses AJAX.NET and Framework 2. They want the application converted to Visual Studio 2013 from Visual Studio 2005, so that it uses Framework 4.5. My question is: what about the AJAX.NET controls? How can they be migrated? I suppose the...

Should I update my Laravel 4 application to Laravel 5 or create a new Laravel 5 application

php,laravel,laravel-4,laravel-5,upgrade
I've got a couple of Laravel 4 applications that I want to upgrade to Laravel 5. Normally I would use the Laravel docs upgrade guide to achieve an upgrade to the next version. But earlier today I read a blog post from Matt Stauffer stating the following: Taylor has said...

Is it possible to program an Arduino from another embedded device?

arduino,embedded,upgrade
I am currently working on a system (home projects - finally got the time yay!) and i am wondering whether it would be possible to program an arduino from a pic32? the system currently has both and given the pic32 proc has an SD card attached, i figured i could...

Worklight 6.2 migration tool connection

oracle,migration,worklight,upgrade
I am working to upgrade Worklight from 5.0.6.2 to 6.2 And am now doing the database upgrade thing. I am stuck when trying to run migration tool as following error is shown "fwlse3401e Failed to connect to source database" It's a local dev oracle express 11g with service name: xe...

SSL_connect gives error SSL_ERROR_SSL after 0.9.8.y to 0.9.8.zb upgrade

ssl,openssl,ssl-certificate,upgrade
My application works fine when fresh install with openssl 0.9.8.y It works fine when fresh install with openssl 0.9.8.zb But when I upgrade application from openssl 0.9.8.y to openssl 0.9.8.zb, it fails; SSL_connect fails and gives error SSL_ERROR_SSL. Anyone has any idea why this behavior? Anyone faced similar problems?...

Upgrade step to remove profile

plone,upgrade,genericsetup
We have one package that we identify that we don't need its profile (collective.js.cycle2) so I need to write an upgrade step to remove the existent profile. Looking at the code I usually have to update profile, I found that in the end it calls: portal_setup.runAllImportStepsFromProfile(profile, purge_old=False) Is it a...

breeze.js - how coupled are the client and server versions

version,breeze,upgrade,server
I have a SPA that uses breeze on the client, and also using the .Net wepapi2/EF6 server libraries. My current version for the client library is : version:"1.4.6" metadataVersion:"1.0.5" The server DLL's have varying version #'s but were installed with the client lib at the same time, so pretty sure...

How to install mysql 5.6 in ubuntu 12.04

mysql,ubuntu-12.04,upgrade,mysql-5.6,mysql-5.5
I was needed to upgrade mysql 5.5 to 5.6, to avoid some issues on importing sql files. ERROR 1293 (HY000) at line 231: Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause How do you upgrade it?...

Retarget to Windows Phone 8.1

c#,windows-phone-8,windows-phone-8.1,upgrade
The app is live on the Windows Store and has a 8.0 version. If I re-target to Windows Phone 8.1 and publish with new features, will it be available for Windows Phone 8.0 users? Most of our users are still on 8.0....