FAQ Database Discussion Community


Use TermExtractor in Laravel 5

php,laravel,composer-php,packagist
I would like to use a library called term-extractor (https://packagist.org/packages/fivefilters/term-extractor) in Laravel 5. I tried to install it via composer with composer require "fivefilters/term-extractor:*" I think, this step was sucessfull as i found the following directory: vendor/fivefilters/term-extractor. As well a line was added to composer.json: "require": { "laravel/framework": "5.0.*", "fivefilters/term-extractor":...

Creating package on Packagist and the package installation path

php,github,composer-php,yii2,packagist
I have created a yii2 extension. It is a Yii2 widget. I created a GitHub repository for it. After some issues with composer.json I have, successfully, to this Packagist package. Now I could able to install it using composer in any yii2 appliaction using the following command: composer require saidbakr/yii-jui-themes-list=1.2...

Composer custom installer paths with WPackagist

php,wordpress,wordpress-plugin,composer-php,packagist
By default, dependencies from http://wpackagist.org/ install to /wp-content/plugins or /wp-content/themes to mimic the default locations for WordPress but I've previously been able to specify that dependencies from http://wpackagist.org/ should go in a specific directory with the following: "extra": { "installer-paths": { "vendor/{$name}/": ["type:wordpress-plugin"], "vendor/{$name}/": ["type:wordpress-theme"] } } i.e. to put...

Having trouble installing barryvdh/laravel-ide-helper via composer - class not found error in Laravel 4 project

php,github,laravel-4,composer-php,packagist
I have the following composer.json file for my Laravel 4.2.x project: { "name": "laravel/laravel", "description": "The Laravel Framework.", "keywords": ["framework", "laravel"], "license": "MIT", "type": "project", "require": { "laravel/framework": "4.2.*", "cartalyst/sentry": "2.1.*", "way/generators": "2.*", "laracasts/flash": "~1.0", "guzzlehttp/guzzle": "~4.0", "itsgoingd/clockwork": "1.*", "barryvdh/laravel-ide-helper": "[email protected]", "intervention/image": "dev-master" }, "autoload": { "classmap": [ "app/commands", "app/controllers",...

How to force a package to be installed?

php,composer-php,laravel-5,cartalyst-sentry,packagist
I'm trying to install the following package through composer: https://packagist.org/packages/cartalyst/sentry#dev-feature/laravel-5 When I do: composer require cartalyst/sentry dev-feature/laravel-5 I always receive this error: [InvalidArgumentException] Could not find package dev-feature/laravel-5 at any version for your minimum-stability (stable). Check the package spelling or your minimum-stability If I change minimum-stability to dev it will...

Packagist.org: what does it mean when a package has a version number like: 4.4.x-dev?

packagist
When browsing the packagist.org repositories you see packages with these version numbers e.g. If you look at the Phpunit repo There are a few instances 4.5.x-dev 4.3.x-dev 4.2.x-dev Do these packages contain the current work the developers are performing towards basic updates, security and bugfixes etc on an otherwise basically...

Symfony2 - github - publishing packagist

symfony2,github,composer-php,packagist
A main problem is that triggers error on composer require package. I'm trying to publish Symfony package using packagist. I have already commited with composer.json: { "name" : "vendor/package", "description" : "Some description", "type" : "symfony-bundle", "authors" : [{ "name" : "Name", "email" : "[email protected]" }], "keywords" : [ "keywords"...

composer create-project - command donot work

composer-php,packagist
I have my project on github containing composer.json in the root directory. This is how my composer.json code looks like: { "name": "vendor/projectname", "description": "My first Composer project", "authors": [ { "name": "John Deo", "email": "[email protected]" } ], "prefer-stable": true, "minimum-stability": "dev", "require": { "php": "~5.3" } } I had...