FAQ Database Discussion Community


Asynctask issue on android version < 4

android,android-asynctask,handler,android-4.0,android-2.3-gingerbread
I have developed an app to support android os 4 and above. I have used an Asynctask to make an web service call during app start up. Later I have changed my minSdkVersion to 9. To support android 2.3 and above. But the same code throws below error. Calling AsyncTask...

emulator: ERROR: There is no user data image in your build directory. Please make a full build

android-emulator,android-source,android-2.3-gingerbread
I'm doing android open source project and I'm new to aosp. I am building gingerbread in Ubuntu 14.04 64-bit. I have managed to successfully compile the source code without any error, and now when I run the command 'emulator', I get the following error and my emulator is not running...

onPrepareOptionsMenu only called once on Android 2.3

android,android-menu,android-2.3-gingerbread
I am putting some code to dynamically control the visibility of some menu items in Activity.onPrepareOptionsMenu. It works perfect on android 5.0. However, when I tried it on android 2.3, I found onPrepareOptionsMenu is called only once during the life time of the entire app. And the trouble with that...

INSTALL_FAILED_OLDER_SDK when trying to run on an Gingerbread device

android,android-studio,android-2.3-gingerbread
I read some stuff on the net about this problem. But the solution presented did not solve my problem. I've a Android device with enabled usb debugging and Android 2.3.6 running on it. I downloaded Android Studio and downloaded the SDK API 10 (Android Version 2.3.3) and I added the...