FAQ Database Discussion Community


Running RubyTest in Sublime Text 3 throws errors

sublimetext3,rbenv,ruby-test
I'm using RubyTest in Sublime Text 3, opening Sublime from my terminal using the subl command, and running into the following error: [MY_HOME_DIRECTORY]/.rbenv/versions/2.1.2/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- bundler/setup The only change I've made in my RubyTest user settings is setting "check_for_rbenv" = true. You'll notice from the error...

Gem installation fails after use of Bundler for cups gem

ruby-on-rails,ruby,gem,bundler,rbenv
So I'm currently working on a project with RoR in a linux environment that involves a print server. We're using CUPS (see http://cups.org). I'm trying to bundle all the various gems that I'm using but this is the only one that doesn't work. I've cp'd the command prompt output and...

Can't find rbenv after puppet install

puppet,rbenv
I am using puppet to setup a ruby on rails server (14.04). The install seems to work fine but then I can't find rbenv or bundler and ruby -v reports the system ruby 1.9.3. Install plugin module puppet module install jdowning-rbenv pp file class rails-test_server { include ruby class {...

Bundler can't find a gem that I can install using gem install

ruby,gem,bundler,rbenv
I am developing two gems side-by-side, one that contains some pure ruby functionality and one with an interface for Rails. The Rails gem (rwanda-rails) depends on the pure Ruby gem (rwanda) with spec.add_runtime_dependency "rwanda" "~> 0.6.0" in the .gemspec. However, for some reason bundler can't find this new version --...

rbenv doesn't work on ubuntu with rbenv and ruby-build?

ruby-on-rails,ruby,linux,ubuntu,rbenv
I just installed rbenv and ruby-build on my ubuntu server. This is ubntu version: Description: Ubuntu 14.04.1 LTS Release: 14.04 And I installed rbenv 0.4.0 There are two problem with rbenv. First it doesn't show latest version of ruby when I type following command: rbenv install -v The result would...

How to install a gem globally without sudo using rbenv?

ruby,gem,sudo,rbenv
I am using rbenv and I am trying to install sass without success. So, I installed rbenv via Homebrew, then Ruby 2.2 (rbenv install 2.2) and finally gem install sass, but I was unable to make sass available on my $PATH. Short on time, I sudo gem install sass using...

Installing optipng with homebrew: command not found (rbenv?)

osx,terminal,rubygems,homebrew,rbenv
I've successfully installed optipng: $ brew install optipng ==> Downloading https://downloads.sourceforge.net/project/optipng/OptiPNG/optipng-0.7.5/optipng-0.7.5.tar.gz Already downloaded: /Library/Caches/Homebrew/optipng-0.7.5.tar.gz ==> Patching patching file src/optipng/osys.c ==> ./configure --with-system-zlib --prefix=/usr/local/Cellar/optipng/0.7.5 --mandir=/usr/local/Cellar/optipng/0.7.5/share/man ==> make install 🍺 /usr/local/Cellar/optipng/0.7.5: 6 files, 156K, built in 2 seconds but when I use the command it...

Ruby on Rails does not use the version defined in rbenv

ruby-on-rails,ruby,rbenv
I want to use version 2.2.2 of Ruby, then [email protected] ~/ApenasMeu/myapp $ rbenv global system [email protected] ~/ApenasMeu/myapp $ rbenv versions system * 2.2.2 (set by RBENV_VERSION environment variable) However, the default home page of RoR, it appears that use this version: Ruby version 1.9.3-p484 (x86_64-linux) How to solve it?...

Cannot find openuri

ruby-on-rails,ruby,bundler,rbenv
I'm trying to run bundle install on my rails project (I've just added Nokogiri) but I ran into a permission error. I installed rbenv (which seems like the right way to go) to get around that problem but now I'm getting Could not find gem 'open-uri (>= 0) ruby' in...

Cant make my rails console work

ruby,rbenv,rails-console
[email protected]:~/Appp$ rbenv local rbenv: no local version configured for this directory [email protected]:~/Appp$ rbenv global 2.2.1 [email protected]:~/Appp$ rbenv versions * 2.2.1 (set by /home/eze/.rbenv/version) I recently uninstalled and reinstalled ruby with rbenv, but when I installed again I realized that everything worked except from the rails console, this is the output...

Why does rails server Welcome Aboard site report a different ruby version to rbenv?

ruby-on-rails,ruby,ruby-on-rails-4,rbenv,multiple-versions
I am using rbenv on Debian. Debian came pre-installed with ruby 1.9.3. I installed rbenv and used it to install ruby 2.1.2. I then used rails new to make a fresh rails application. rbenv versions gives system * 2.1.2 (set by /home/jordanmorris/code/TestRail/.ruby-version) rbenv global gives 2.1.2 rbenv local (in the...

VPS rbenv location directory is wrong when using Capistrano3

ruby-on-rails,rbenv,capistrano3,centos7
My Centos 7 has rbenv located in /root/.rbenv, but when I run cap production deploy:setup_config it searches rbenv inside /usr/local/rbenv. Error Message DEBUG [6a1407a4] Running /usr/bin/env [ -d /usr/local/rbenv/versions/2.2.0 ] as [email protected] DEBUG [6a1407a4] Command: [ -d /usr/local/rbenv/versions/2.2.0 ] DEBUG [6a1407a4] Finished in 6.403 seconds with exit status 1 (failed)....

rbenv: “bundle exec spring” not working…?

ruby-on-rails,ruby,bundler,rbenv
why doesn't bundle exec spring work? i am already calling bundle exec and that returns an error. i am okay with calling bundle exec all the time. (this is the solution to the possible duplicate question). i will not update my Gemfile (via bundle update spring) or uninstall a version...

.bash_profile conflicting with .profile preventing node from running

node.js,macports,rbenv,.bash-profile,.profile
I have my ruby environment set up in .bash_profile and MacPorts installed in .profile, as per its instructions. I've installed node using MacPorts, but it seems like there's a conflict between .bash_profile and .profile. Node worked upon installation, but it hasn't worked since unless I delete .bash_profile or load .profile...

Gem installed but 'command not found'

ruby-on-rails,ruby,wordpress,terminal,rbenv
I've installed a Ruby gem called wordmove to work with pushing and pulling my Wordpress sites but when I run wordmove commands I get the error command not found. I've done some research and I haven't come up with much, I've come to the conclusion based on what I've seen...

Trying to update a jekyll site …

ruby,bash,jekyll,rbenv
I'm trying to update a jekyll blog ... and wanted to view it on my browser first ... So, I ran jekyll serve. This is what I get: rbenv: jekyll: command not found The `jekyll' command exists in these Ruby versions: 2.1.0 Why do I get this error? I also...

Rbenv fails when installing rubinius 2.5.2

ruby,rbenv,rubinius
Rbenv with ruby-build fails when installing rbx-2.5.2. System: Lubuntu 14.10 Full log can be found at https://gist.github.com/sgoblin/89034c14e8426f400b68 Output of command: Downloading rubinius-2.5.2.tar.bz2... -> http://dqw8nmjcqpjn7.cloudfront.net/1b077537224d4ff1f8c628e5bbe0621dc6f833bc2d67a03aa10173b72299a1a8 Installing rubinius-2.5.2... BUILD FAILED (Ubuntu 14.10 using ruby-build 20150130-2-g8106d8f) Inspect or clean up the working tree at /tmp/ruby-build.20150213212239.19770 Results logged to...

Install Latest Stable Version of Ruby Using rbenv

ruby,bash,shell,sed,rbenv
I want to install the latest stable version of Ruby available with rbenv. This feature won't be happening in rbenv itself. When I run the command rbenv install -l in my shell, I get a long list of available versions. The list has all types of entries. The following is...