FAQ Database Discussion Community


cannot start rails 4 console on production server

ruby-on-rails,ruby,ruby-on-rails-4,console,production
having a weird issue and need help. I am trying to start a rails console on a production server and it is acting like the rails c command does not exist. FWIW, I have been a rails developer for 4 years and do this all the time on a plethora...

Is there any sdk to log exceptions, events and errors in production app?

android,logging,error-handling,sdk,production
I want to catch all the un expected/undesirable events in my app during production. I want something which can send a error log file to server and I can easily read it through a web application. Do you know anything of this sort ?

Change mail subject with Elao\ErrorNotifierBundle

php,email,symfony2,production
Everything in the title! Just want to know if it's possible or not to change the mail subject, I'm working with Symfony2.6 and the Elao\ErrorNotifierBundle to send error mails in the prod environment. Thanks!...

how to deal with logging in production code (logback/slf4j)

slf4j,logback,production
I've implemented an algorithmic framework consisting of several classes. For logging, I use slf4j and logback. So many of my classes have code like: protected final Logger logger = LoggerFactory.getLogger(Myclass.class); ... logger.debug("Some debug information"); Now I would like to package my code and make it production ready. What do I...

Git push to DigitalOcean from Bitbucket or Cloud9

git,heroku,bitbucket,production,cloud9-ide
I'm making site on Cloud9 IDE and I can't find the way to easy push my production code to DigitalOcean droplet server. Maybe there is some simple way I could do it as easy as it is to push code to Heroku from Cloud9. With simple command from Cloud9 console....

Error on Laravel 4 production: Call to undefined method Illuminate\Database\QueryException::message()

database,laravel,methods,views,production
I'm managed to set up a L4 project on to a sub directory: http://secure.myultratrust.com/test/users/create#b I have it on a subdomain too: http://test3-l4.ultratrust.com/users/create#b I get this error on submitting: Symfony \ Component \ Debug \ Exception \ FatalErrorException (E_ERROR) Call to undefined method Illuminate\Database\QueryException::message() (BTW, ignore the #b at the end...

Rails deployment with Capistrano failing

ruby-on-rails,deployment,capistrano,production
I'm pretty new to RoR and deploying apps like these into production, so I've been doing quite a bit of reading. There's one problem I can't seem to get past however. During my investigation, I came upon a thread on SO that indicates the behavior of Capistrano v3.x changed, which...

Rails deployment in production - always complain about dalli

ruby-on-rails,ruby,deployment,production,capistrano3
Using I can't get rid of this error when trying a production deployment Could not find cache store adapter for mem_cache_store (cannot load such file -- dalli) (RuntimeError) I really don't understand. So far I've had no problem deploying in development, and even if I change copy /environments/development.rb into /environments/production.rb,...

wordpress // working with github, deploying, etc…

wordpress,plugins,deployment,production
What would a wordpress expert would recommend to develop robustly, and deploy things in production ? Tools to recommend ? I'm looking for a setup or tools that experienced wp devs use Thanks for sharing...

Play Framework app can't be deployed when ssh session stopped

scala,ubuntu,playframework-2.0,server,production
I am trying to deploy a play framework app on my remote virtual private server hosted by OVH. My VPS is on ubuntu 14.10 server. Therefore, I read the documentation and I used the command line: activator start instead of activator run to deploy in production my app. I can...

Rails - jQuery not working in production with Heroku

javascript,jquery,ruby-on-rails,heroku,production
I'm deploying a website with Heroku, though really struggling to get the jQuery firing when it goes live. Locally, all works fine. I've had a play and haven't found any solution - it's all loading in the asset pipeline, shows as a source on the live page (albeit without working)...