FAQ Database Discussion Community


PHP-DI is not working in integration with ZendFramework2

php,zend-framework,zend-framework2,php-di
Could you please give a hint why PHP-DI integration with Zend Framework 2 is not working for me (reproduced with Apache/2.4.9 (Win64) PHP/5.5.12 and Apache/2.2.22 (Win32) PHP/5.3.13). composer.json: { "require": { "php": ">=5.3.3", "zendframework/zendframework": "2.3.5", "mnapoli/php-di": "4.4.6", "mnapoli/php-di-zf2": "0.3.0", ... }, ... config\application.config.php: <?php return array( 'modules' => array( 'Morpho',...

Getting started PHP-DI without any 3rd party framework

php,dependency-injection,php-di
I am just now discovering dependency injection and I want to apply it to a medium sized project which I've been working on. I already have a classes folder which holds all the classes used in the system /application/core/classes I would like to know how I can configure PHP-DI to...

PHP-DI annotation not working

annotations,inject,php-di
I have installed php-di 4.4 in a new custom project using composer.Im runing a xampp localhost with php 5.6.3 but I set netbeans for php 5.4 on this project. Im new to php-di, I did use annotations in my android projects but cant seem to make it work here. The...