FAQ Database Discussion Community


how to know the installed version of a library by macports

macports
I've installed opencv via macports. I would like to know the version of the library through macports. Is there any option that allows me to acquire the installed version?

Python “Segmentation fault: 11” when running “import cv” or “import cv2”

python,osx,python-2.7,opencv,macports
I have installed numpy and opencv using macports as per these instructions, but when I try import cv or import cv2 I just get the segfault and I have no idea why. Any suggestions? $ python Python 2.7.6 (default, Sep 9 2014, 15:04:36) [GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.39)]...

Macports switch PHP CLI version

php,bash,drupal,terminal,macports
I'm trying to switch my Terminal PHP version to 5.4 because I ran into some issues with Drush while updating my Drupal core. http://drupal.stackexchange.com/questions/112090/drush-command-errors The reason for these issues is my Terminal PHP version is different then my localhost. php -v in Terminal returns PHP 5.5.13 (cli) but my localhost...

Macports' dropping of privileges causing Xcode licence problems

xcode,licensing,sudo,macports,privileges
I am trying to install some ports using Macports on OS X but as soon as the installation tries to invoke the C compiler I get: Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo. Context: I have run sudo xcodebuild -license and successfully agreed...

.bash_profile conflicting with .profile preventing node from running

node.js,macports,rbenv,.bash-profile,.profile
I have my ruby environment set up in .bash_profile and MacPorts installed in .profile, as per its instructions. I've installed node using MacPorts, but it seems like there's a conflict between .bash_profile and .profile. Node worked upon installation, but it hasn't worked since unless I delete .bash_profile or load .profile...

Difference between from PIL import Image and import Image

python,python-imaging-library,homebrew,macports,pillow
I tried to use Python's Image Module on my Mac (new to mac)and I had trouble setting it up. I have Yosemite and some of the posts that I found online didn't work. I ended up installing Homebrew and I finally got PIL on my computer. However, instead of using...

boost logging fails to compile on OSX

c++,osx,boost,macports
trying to use Boost.Log on OSX (via MacPorts) /* * Copyright Andrey Semashev 2007 - 2013. * Distributed under the Boost Software License, Version 1.0. * (See accompanying file LICENSE_1_0.txt or copy at * http://www.boost.org/LICENSE_1_0.txt) */ #include <boost/log/core.hpp> #include <boost/log/trivial.hpp> #include <boost/log/expressions.hpp> namespace logging = boost::log; //[ example_tutorial_trivial_with_filtering void init()...

What is the meaning of the libstdc++6.dylib version number on mac os x?

osx,g++,macports,libstdc++
I try to determine which version of libstdc++ is running by the gcc5.1 port on Mac OS X (Yosemite 10.10.3). The otool command gives the following information: /opt/local/lib/libgcc/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.21.0) What is the meaning of version 7.21.0? libstdc++7 does really exist?...

Macport-installed python can't find macport-installed sip

qt,pyqt4,macports
I am learning PyQt4 by reading Rapid GUI Programming with Python and Qt and am at chapter 7 which covers QT Designer; however QT Designer doesn't appear to be installed with my MacPort's (py34-pyqt4) or the example code from the book's website www.qtrac.eu. So I'm downloading QT Designer from www.qt.io....

How to install PostgreSQL on OSX Yosemite using MacPorts

postgresql,osx-yosemite,macports
I want to install PostgreSQL for a node project that I'm developing in OSX Yosemite. I use MacPorts and so tried the method described here: https://github.com/codeforamerica/ohana-api/wiki/Installing-PostgreSQL-with-MacPorts-on-OS-X ...but I get an error during step 2: $ sudo gem install pg -- --with-pg-config=/opt/local/lib/postgresql93/bin/pg_config > ruby_error ERROR: Error installing pg: ERROR: Failed to...

Why does cmake ignore ADD(SYSTEM) header files when CXX is defined?

c++,osx,cmake,macports
I've bumped into the following annoying issue. I installed g++ via macports on OSX, everything works fine. However, cmake still detects clang++ as the cpp compiler. Therefore, I end up putting export CXX=/opt/local/bin/g++ in my profile. Now, cmake correctly detects g++ as the compiler. The problem is that all the...

Emacs: how to bind action to mac Option (⌥) + arrow key combinations?

osx,emacs,macports,keymapping,keymaps
I'm using Emacs on OS X from mac ports. By default I have Ctrl as Control key, and ⌘ Command as Meta key. Thogh, this is quite handy, I'm missing possibility to move cursor one word backward/forward by pressing M-arrrow key, i.e. ⌘+← to move one word forward. What I...

Can't locate libraries installed with MacPorts

c++,osx,macports,phash
I've installed pHash libraries using MacPorts but when I try to compile the example source code I get this error: Fatal error: 'pHash.h' file not found #include "pHash.h" How can I tell the source code where to find the libraries? (from what I found they are installed in /opt/local)...

Updating Openssl in os x yosemite

osx,openssl,homebrew,macports,brew
-- Build of crashreporter disabled. -- Found Qt5 core, checking for further dependencies... -- Using Qt 5! -- GIT_SHA1 40cdbda31285d9090d8109b10b244aa4740a5891 -- Using Qt 5.4.x -- We would not require Neon in this setup, compile without! CMake Error at /usr/local/Cellar/cmake/3.1.3/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:138 (message): Could NOT find OpenSSL, try to set the path to...