FAQ Database Discussion Community


Installing libxslt on CentOs 6.5

python,centos,yum,libxslt
I am trying to install lxml using pip which gave me errors as libxml2 and libxslt were not installed. I tried installing them using yum. libxml2 was successfully installed but nothing happens when I give sudo yum install libxslt. The output is as follows [[email protected] Downloads]# yum install libxslt Loaded...

How to calculate max string-length of a node-set?

xml,xslt,xslt-1.0,libxslt
I am trying to use XSLT to turn an XML document into plain text tables for human consumption. I am using xsltproc, which only implements XSLT 1.0 (so max is from EXSLT actually). I tried the below, but the commented-out definition fails because string-length returns only a single value (the...

libxslt: compilation errors

ios,libxslt
I'm using libxslt on iOS, and I'm getting compilation errors from what should be straightforward xslt, such as: compilation error: file /Users/yada/Library/Developer/CoreSimulator/Devices/ACE15E20-3230-4966-ACDE-DCADABF48B32/data/Containers/Bundle/Application/A4EC9B34-3A96-42E0-B58F-6EB44C942874/appname.app/upconversion-options.xsl line 19 element function xsltStylePreCompute: unknown xsl:function compilation error: file...

Unable to install Nokogiri with dependencies on Redhat Linux

ruby-on-rails,ruby,nokogiri,libxml2,libxslt
I am using Ruby 1.9.3 and therefore have to use an older version of Nokogiri. I need to install Nokogiri v1.5.10. Initially I got an error that libxml2 is missing. After installing libxml2 I got the following error: ERROR: Error installing nokogiri-1.5.10.gem: ERROR: Failed to build gem native extension. /opt/ruby-1.9.3/bin/ruby...

xmllint warns about missing space of xslt generated file

xml,xslt,xmllint,libxslt
When running xmllint on a xml file generated by xsltproc, I get the following error: xmllint --valid --noout build/docbook/index.xml :( build/docbook/index.xml:1: parser error : Space needed here <?xml version="1.0"?> ^ Is this space really necessary? Is this an issue of xsltproc?...

ValidationException during PDF generation from XML using libxslt

xslt,pdf-generation,libxslt,docbook-xsl
I am using Docbook 1.78 and xsltproc (libxslt 1.1.26 with libxml 2.7.8) in command line to generate a fo-file from an XML file. My aim is to generate a PDF using Apache formatted output processor (fop; version 1.1). My XML-Input file: <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE book SYSTEM "http://www.oasis-open.org/docbook/xml/4.4/docbookx.dtd"> <book lang="de"...