FAQ Database Discussion Community


Is there a reliable way to get unique identifier for iOS device in 2015?

ios,install,udid
is there a reliable way to get unique identifier for iOS device in 2015 there will be the same even after reinstalling an app?

android how to install apk silently?

android,permissions,install
I'm trying to make an app that installs apk silently. But when I try, it always gives errors. I dont really get what I should do now. I think I've already tried all the ways posted on the web. Can anyone help me know anything else I should try now?...

iOS app not installing - have tried everything

ios,cordova,install,apple
I have spent several frustrating hours searching through mostly this site looking to see if anyone else has had this problem. The problem I have is that my app will not install on my iPad, nor would it install on the apple review persons ios device (thus it is not...

How to grant a folder with write permissions for installing gems in Ruby

ruby-on-rails,ruby,gem,install
the biggest problem I have with installing anything on my computer related to Ruby and Rails, is not having 'write' permissions to a specific folder. For example: "You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory" Instead of always using Sudo command, which sometimes doesn't solve the problem, how can...

Laravel vagrant up errors

laravel,cygwin,install,vagrant
I am trying to setup Laravel homestead on a windows machine according to the documentation here: http://laravel.com/docs/5.0/homestead#installation-and-setup. However when I get to the 'Launch The Vagrant Box' step I get the following error when I try to 'vagrant up' from cmd: D:/Homestead/scripts/homestead.rb:4:in `configure': undefined method `[]' for false:FalseClass (NoMethodError) from...

createrepo using --split option for a multi CD distribution

linux,centos,install
I am trying to create a customized CentOS multi CD installation. Our current distribution just grew past the size of a CD. Sure, you can just burn it on a DVD. Well, we have customers with old machines that do not support DVDs so I have to create a distribution...

Installing modules with Julia

git,module,install,package,julia-lang
I am trying to install some the Distributions and StatsBase modules on a cluster but I fail. Here is what I did and the error message I got: julia> Pkg.add() ERROR: `add` has no method matching add() # Not really relevant for our problem I guess Pkg.add("Distributions") ERROR: could not...

Getting a permission error when installing with bower

permissions,install,bower
Everytime I try to install something with Bower I get a permission error like this: Andreass-MacBook-Air:openMedia Andreas$ bower install jquery /usr/local/lib/node_modules/bower/node_modules/configstore/index.js:56 throw err; ^ Error: EACCES, permission denied '/Users/Andreas/.config/configstore/bower-github.yml' You don't have access to this file. at Error (native) at Object.fs.openSync (evalmachine.<anonymous>:500:18) at Object.fs.readFileSync (evalmachine.<anonymous>:352:15) at Object.create.all.get...

Bundle Install, Ruby on Rails, rubyinstaller

ruby-on-rails,ruby,install,bundle
I'm completely new to Ruby on Rails, and I'm a few difficulties creating a new rails project. Each time the 'bundle install' command runs I get the following error: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. C:/Ruby193/bin/ruby.exe -r ./siteconf20150226-7776-brvf10.rb extconf.rb checking for rb_method_entry_t.called_id in method.h... no checking for rb_control_frame_t.method_id...

How do I override the Ruby and Ruby DevKit installdir with Chocolatey?

ruby,install,chocolatey,ruby-development-kit
I am somewhat new to chocolatey, having installed a few packages in the past on Windows 8, and I have come to like it. I have noticed that chocolatey installs the packages in the default Windows program directory (i.e. "Program Files x86" or so). Maybe there is more to that...

Laravel 5 composer install fails (psysh, php-parser, ext-tokenizer errors)

php,laravel,install,composer-php,laravel-5
Running $ composer create-project laravel/laravel fails with error: Installing laravel/laravel (v5.0.1) - Installing laravel/laravel (v5.0.1) Downloading: 100% Created project in /Users/androidu/Workspace/phpstorm/laravel Loading composer repositories with package information Installing dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - laravel/framework v5.0.6 requires psy/psysh...

What do I need to install on a WP8 device that capable it to run my app writen by wp8 and SQL Server CE 3.5?

windows-phone-7,windows-phone-8,install,sql-server-ce-3.5
Please give me link of program that can capable phone wp8 run my application that written by Wp8 and VS.net 2013 and SQL Server CE 3.5. Please give me link of software that I need to install on the phone....

installing isc-dhcp-server, “has no installation candidate” [closed]

linux,install,dhcp
I'm trying to instal isc-dhcp-server on my kali box. I first tried dhcp3-server, then found that it was replaced by isc-dhcp-server, however when I run sudo-apt get install isc-dhcp-server, I get the error "Package isc-dhcp-server has no installation candidate". Am I missing a repo or something along those lines where...

Why cant application find this libSDL2_image-2.0.so.0 library? - Ubuntu 14.04

c++,linux,install,shared-libraries,ubuntu-14.04
I have an application which depends on this library libSDL2_image-2.0.so.0 So I compiled from source - which I obtained from SDL image website The compilation and install ran with no errors make install put the library here: /usr/local/lib/libSDL2_image-2.0.so.0 when I try to launch main application terminal errors out with: error...

Sylius2 Install Dabatase Error

php,database,symfony2,install
Im trying to install Sylius. I already create the project with: composer create-project -s dev sylius/sylius. But when im try to do the setup with: php app/console sylius:install I get this error of nesting leves max reached: Success! Your system can run Sylius properly. Step 2 of 4. Setting up...

IP Messenger for CentOS 7

centos,install,messenger
I'm Using CentOS 7 and trying to install IP messenger in it but not able to install it. Can anyone help me in installing any IP messenger. Any kind of help would be appreciated. Thanks.

Installing matplotlib on RedHat ideally using yum

python,linux,matplotlib,install,yum
I can't seem to find documentation on this. Matplotlib says to run: sudo yum install python-matplotlib which installs all the dependancies and this version of matplotlib successfully: python-matplotlib.x86_64 0:0.99.1.2-1.6.amzn1 However, I use python2.7, separately installed. The original (and still existing) python2.6 now imports matplotlib successfully. Is there a related matplotlib...

ImportError: No module named cassandra

django,cassandra,install
I'm trying to get Cassandra to work with Django using Windows 7 for the first time. I've installed Django, Cassandra and django_cassandra_engine. However when I open a new Django project I get the following errors. C:\Python27\python.exe -u C:\Program Files (x86)\JetBrains\PyCharm 4.5.1\helpers\pydev\pydevconsole.py 54467 54468 PyDev console: starting. import sys; print('Python %s...

ImportError: No module named scitools.std,anaconda already installed

python,install,scitools
I have installed anaconda and scitools with sudo.Where is the the problem?I got this: from scitools.std import * ImportError: No module named scitools.std What should I check? echo "$PATH" /home/milenko/anaconda/bin:/` ...

ImportError: No module named opencv after installing python-opencv in Ubuntu 14.04

python,opencv,ubuntu,install,ubuntu-14.04
I install opencv in python with running $ sudo apt-get install python-opencv and installed successfully. but when run this code import opencv import opencv.highgui import time import commands def get_image(): image = opencv.highgui.cvQueryFrame(camera) return opencv.adaptors.Ipl2PIL(image) camera = opencv.highgui.cvCreateCameraCapture(-1) while 1: image = get_image() image.thumbnail((32, 24, )) image = tuple(ord(i) for...

install issue with python - spacy package in anaconda environment

python-3.x,install,nlp,anaconda,spacy
I'm attempting to follow this tutorial to install the natural language processing package spaCy into a python 3 anaconda environment, windows 8 I opened console, cd-ed to my site-packages folder, activated environment, pip-ed for install, everything seemed fine except I couldn't run the second command here $ pip install spacy...

Installing jQuery For School Final [closed]

javascript,jquery,html,css,install
I am working on my final website for school. I am wondering how to install jQuery. This project will have html, css and .js files zipped into one folder which my teacher will download to his computer. Quite frankly I can not even get it to install by myself. I...

Error installing sqlite3, Failed to build gem native extension

ruby-on-rails,sqlite3,gem,install
I've referred to the following solution on stackoverflow, yet I'm still experiencing the same issue: (Error installing mysql2: Failed to build gem native extension), The below command referenced in the link above did not remediate the issue: brew install mysql Evidently, the issue persists, returning the following output: Gem::Installer::ExtensionBuildError: ERROR:...

WiX Boostrapper - Minor Upgrade

wix,install,windows-installer,bootstrapper,burn
I have a bootstrapper which is built using Burn and installs a package which i have setup to allow for minor upgrades when i run the msi packages using REINSTALL=ALL REINSTALLMODE=vomus from the command prompt (as per this article in the WiX docs). However currently trying to upgrade with the...

Sitefinity Invalid root node configured for pages. No root node with the name of “f669d9a7-009d-4d83-ddaa-000000000002”

install,sitefinity
I trying to run a local instance of Sitefinity 8.0.5700.0. My steps to run site locally: Restored a backup of an existing database to (localdb)\v11.0 (database schema) Setup IIS site named Default (binding localhost) in IIS under LocalSystem Indentity DataConfig.config connection string changed to Data Source=(LocalDB)\v11.0;Integrated Security=True;Database=Sitefinity Run site http://localhost,...

Installing pylab on Mac OSX

python,osx,matplotlib,installation,install
I've looked at many questions on this issue, but none seem to help. I am new to Python and programming. I am not sure if installing matplotlib is what I need to do, but it was the link given in my textbook (I am self studying, so there's no one...

Error when i try to install npm with putty

amazon-ec2,npm,install,runtime-error
here is what i get when i try to execute this command (the 3rd command - in ec2 amazon) The next step is to install NPM(Node package manager). Type the following commands: 1. git clone https://github.com/isaacs/npm.git 2. cd npm **3. sudo make install** and here is the error i get:...

Install package into custom directory Composer

path,install,package,composer-php
Hey I am trying to install a package into a custom 'admin' directory using composer. Here is my JSON: { "name": "frontier/installer", "description": "The best front end engineer package around", "require": { "aheinze/cockpit": "*" }, "extra":{ "installer-paths":{ "admin": ["aheinze/cockpit"] } } } Now when I run composer install it all...

Call 'sudo make install' from gvim

vim,makefile,install,sudo
I am developing a program which has a fairly standard looking Makefile like the one below. .PHONY=default install hello: hello.o install: hello cp hello /usr/local/bin This example Makefile builds a program called hello from a file called hello.c and has an installation rule to install it to a directory which...

Unspecified error trying to install .NET 4.5.2 Developer Pack

install,.net-4.5.2
I downloaded the .NET 4.5.2 Developer Pack and have since been struggling to install it on one particular 64-bit Windows 7 machine so that I can use it with Visual Studio 2013, which was successfully installed. (Worked just fine on all other machines I've installed the framework on) It fails...

NSIS executes exe but not running the exe

installation,install,nsis
I'm currently trying to compile an installer with NSIS but it is not working properly. I have the code: Section "Main" MAIN ; installs the primary DetailPrint "Starting setup..." SectionIn RO File "setup.exe" ExecWait "$INSTDIR\setup.exe" Delete "$INSTDIR\setup.exe" SectionEnd The finished installer says that it is executing setup.exe but it is...

How do I run only some makefile commands as root?

c,makefile,make,install,sudo
I have an install target in my Makefile and wish to run some commands that install shared libraries(requires root permissions) and some that install config files into $HOME/.config Usually I'd just tell the user to run sudo make install, however that results in the config file being installed to /root/.config...

Is there an offline MinGW installer?

c,gcc,installation,windows-installer,install
I am learning C and I want to install MinGW on my laptop. The MinGW installer is a web-installer, it requires the computer to have access to the internet when installing. But the problem is that my computer's not connected to the internet. So it can't be installed. So I...

How can I install Meteor-Up (mup) correctly?

meteor,install,npm,ubuntu-14.04,meteor-up
I am trying to install Meteor-Up (mup) for deploying an app from my Ubuntu 14.04 laptop to a Ubuntu 14.04 server, but it does not seem to install correctly. How can I install mup correctly? I know that I need npm to in order to install mup. So, I have...

yum install firefox error - libnssutil3.so

python,linux,firefox,install,undefined-symbol
I'm getting this error while installing/listing firefox or python on a Linux server. Any ideas how to fix it. # yum install firefox There was a problem importing one of the Python modules required to run yum. The error leading to this problem was: /usr/lib64/libnssutil3.so: undefined symbol: PL_ClearArenaPool Please install...

Cant install a package in R

r,install,package
I cant seem to install this package. package ‘zoo’ successfully unpacked and MD5 sums checked Warning: unable to move temporary installation ‘C:\Users\Xiang\Documents\R\win-library\3.2\file248444b815fb\zoo’ to ‘C:\Users\Xiang\Documents\R\win-library\3.2\zoo’ Does anyone have a solution to solve this problem? Thank you....

Share ImageMagick files over network drive without users installing ImageMagick?

python,imagemagick,install
Is it possible to share ImageMagick files with others over a network drive (ex.: Z:), without having the users install ImageMagick? ImageMagick works fine on my own machine as I used its binary installer and set up Windows environment variable ("MAGICK_HOME"). I tried using Python to auto setup the user's...

Ubuntu - Python installations

python,ubuntu,numpy,matplotlib,install
I have python-2.7.9 installed on my machine and I am trying to install numpy, matplotlib, pyopengl, and pyqt4. I've installed pyqt4 using the source file and it imports fine when using python, however, i get an error for the remaining packages.... no module named numpy. I installed numpy and matplotlib...

Prevent Removing Installed Files if they Have Been Changed NSIS

install,nsis,uninstall
I have a fully functioning NSIS installer and it works great. However, I have just been asked if I could amend the installer so that if any file I install is changed, it is not removed by the uninstaller. At first glance there is no obvious solution apart from writing...

Mongo doesn't start on fresh install on Ubuntu 14.04

mongodb,ubuntu,install
After installing mongodb on 14.04, mongo doesn't work out of the box: $ sudo apt install mongodb-server [...] $ sudo start mongodb mongodb stop/waiting What's happening here, how can I fix it?...

Protobuf 3.0.0-alpha1 install on windows. Virus?

windows,install,antivirus,virus,protobuf-c
I was just trying to install protobuf 3.0.0-alpha1 on windows using MSYS and MinGW, and it fails at checking if my C compiler works. Just as it fails each time, my Norton auto-block window comes up and says that it blocked a.exe because it contains SAPE.heur.3161 virus. Anyone know what...

Android Studio: Android 5 lollipop can't install and launch App

install
I have 2 real android devices and I used them to test my android app (I am new at Android programing) When I clicked "run" button, the dialog box showed me two of my devices: Table 4.2.2 and Cellphone 5.0 After running, my tablet launched the app perfectly, but my...

How to install phpseclib?

php,install,phpseclib
I have installed Apache on my machine so I can use localhost as a PHP server. That works. Right now I am trying to use PHP to send files via SFTP to another server. I looked around a bit and saw phpseclib was recommended. I can't seem to figure out...

Python pip install reportlab error

python,windows,install,reportlab
I am trying to install reportlab for python. I have Windows 7, Python 2.7 and Visual Studio 2013 and I am using the command line "pip install reportlab" but it is not working. I have the pip log file data that was generated - what is the best way to...

Problems installing development package from either GitHub or local

r,install
I've been corresponding with the package author about an error I'm getting in the HLMdiag package. He suggested that I install the development version [https://github.com/aloy/HLMdiag]. So, I'm trying to install the development version from both GitHub and a local version that he sent me. I'm running into errors for both...

Error while installing pygame using pip for python 3.4

python,install,pygame,pip
Sorry, thought i edited to say i am on windows 64 bit When trying to install Pygame using pip, I get the following error: "requirement 'pygame.whl' looks like a file name, but the file does not exist pygame.whl is not a valid wheel filename." I have my file paths right...

How to run an app when it does not show under Apps?

android,debugging,install,adb
I used ant to build my Eclipse project from the command line in a debug configuration. (Eclipse Luna and Android NDK-R10d is broken, so I can't use Eclipse any longer. Confer, Eclipse/ADT plugin cannot locate symbols for r10d NDK). I then performed an install using adb: <Project Directory>$ adb install...

How to install R on Mac OS X 10.10.2 using Homebrew?

r,install,homebrew
How to install R on Mac OS X 10.10.2 using Homebrew? If I simply do brew search R or brew install R it does not do the trick as it did in 10.9....

Datapusher issue (409 Client error) during CKAN setup : maybe a filepath issue?

install,filepath,ckan
I'm writting here about a CKAN installation problem. I have already a functional datastore (I've got answer from the API test) and functional filestore, my config file is OK (all options sets, like site.url , etc...). I can post files on the CKAN site, I can get it, SOLR is...

How to correctly make install of binaries and data after compile in linux?

linux,make,install
After make of sources I have compiled executable file and data directory with images for it. What should I do at "make install" phase to correctly install these files to the linux system? And how then application can find installed data (in case when binary and data are placed in...

How to install RPi.GPIO to windows

python,module,install,raspberry-pi,gpio
I have looked and most of the tutorials are rasbian based. I would like it on windows so I can develop a python script on windows to which would later be put on the Raspberry pi. I have downloaded the module and have tried python setup.py install in command prompt...

Can't install any python package from the python command prompt

python,shell,install,package
I am trying to install some python packages from the python shell but I get syntaxError. I am using python 3.4.3 which supposed to come with pip installed and I can see pip3 pip3.4, pip, easy_install, and easy_install-3.4 under scripts but whenever I run the command in the shell I...

Kivy is not compitable with Cython?

python,install,cython,kivy
I decided to choose kivy to to help me design my gui applications, but I am facing this problem; I installed cython 0.22 and everytime I try to install kivy I get this (with a lot of other lines): ImportError: Incompatible Cython Version Can anyone suggest a way to solve...

How to perform Pub Get programatically from a Dart program

dart,install,yaml,dart-pub
I'm building a Dart framework called Modular for backend development and this framework has a installer for convenience. At the end of the installation, I'd like to install all dependancies in the generated pubspec.yaml file. How would I do this? Thank you

Starts with Symfony2 : No route found for “GET /”

php,symfony2,install
I just installed Symfony2 on my Mac. My web/config.php works fine but when I go to the web/app_dev.php file, it shows me an error : No route found for "GET /" (from "http://localhost:8888/Symfony/web/config.php") 404 Not Found - NotFoundHttpException 1 linked Exception: ResourceNotFoundException ERROR - Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: "No route...

Linux install command for mingw?

windows,make,install,mingw,mingw32
When trying to build a library from source using make and MinGW, I realized (from errors) that I don't have the install command, which I understand to be a combination of cp, chown, chmod, strip, and maybe some other stuff. I figured, hey, someone's got to have a copy of...

Average Function in Pycharm

python,python-2.7,python-3.x,install,average
I'm just starting to learn Python from a book. But I keep running into the same problem when I run my script, it says: File "C:/Users/bob/Desktop/Python/Part3 A.py", line 8, in <module> print(' the average is: ', avg()) File "C:/Users/Bob/Desktop/Python/Part3 A.py", line 6, in avg average = a + b +...

How does one install MarkLogic 8 on Ubuntu 14.04?

ubuntu,install,marklogic
What are the steps to install MarkLogic 8 on Ubuntu 14.04?

Install android sdk in eclipse without downloading full os

android,eclipse,sdk,install,storage
I would like to install the SDK for several android platforms on my chromebook using Ubuntu with crouton when I get it. The problem is that the chromebook I might get only has 16gb minus the OS. Installing the android SDK to eclipse also seems to install the whole emulator...

How can I install MONO on Centos 5, without compiling from source

linux,mono,install,centos5
I would like to install a reasonably recent version of Mono on a CentOs 5 system. Ideally I would prefer not to have to build from source. I set up a mono.repo file in yum.repos.d: [mono] name=Mono Stack (RHEL_5) type=rpm-md baseurl=http://download.mono-project.com/repo/centos/ gpgcheck=1 gpgkey=http://download.mono-project.com/repo/centos/repodata/repomd.xml.asc enabled=1 When I tried to use the...

Error installing nokogiri in ubuntu 14.0.4 (Ruby 1.8.7)

ruby,ubuntu,gem,install,nokogiri
I'm trying to install the bundle(bundle install) in Ubuntu 14.0.4 installed Ruby 1.8.7.And it fails to install the bundle and displayed the error: An error occurred while installing nokogiri (1.4.7), and Bundler cannot continue. Make sure that `gem install nokogiri -v '1.4.7'` succeeds before bundling. so now I tried to...

Install SQL Server 2008 R2 Express using C#

c#,install,sql-server-2008r2-express
I am in a situation where I need to Install SQL Server 2008 R2 Express silently. I want to use C# for this but couldn't get a working solution. Can someone post a working C# code for above scenario?...

How can I change the component of a registry key in Installshield?

windows-installer,install,components,installshield
I have to put a registry key in another component from it's original. How can I make this step without exporting it an importing back in the other component? ...

Fail to install Hackage string-conversions

haskell,install,cabal,cabal-install,hackage
Problem I was installing the Hackage string-conversions. However, it fails with the error below. Error Log Configuring string-conversions-0.3.0.3... Building string-conversions-0.3.0.3... Preprocessing library string-conversions-0.3.0.3... [1 of 1] Compiling Data.String.Conversions ( Data/String/Conversions.hs, dist/build/Data/String/Conversions.o ) In-place registering string-conversions-0.3.0.3... Creating package registration file: /tmp/pkgConf-string-conversions-0.3.011675.3 cabal: Error: some packages failed to install:...

Angular js wont install on my machine

javascript,angularjs,node.js,install
I have node.js installed on my machine, I have version: v0.12.0 installed. Following instructions when I use sudo npm install I get these errors: npm ERR! install Couldn't read dependencies npm ERR! Darwin 14.0.0 npm ERR! argv "node" "/usr/local/bin/npm" "install" npm ERR! node v0.12.0 npm ERR! npm v2.6.0 npm ERR!...

xcode 6.2 cannot install old simulator by coping

xcode,install,simulator
everyone. I found that I cannot install old simulator into Xcode 6.2 by coping now. I tried to download the 7.1 simulator in Xcode, but always get a no response message. Is there another way to install iOS 7.1 simulator for Xcode 6.2? Thanks....

How to Install ROUGE In Ubuntu

perl,ubuntu,installation,install,perl-module
Although there is good description of how to Set Up ROUGE evaluation , i could not get any place where the installation was described completely.