FAQ Database Discussion Community


Getting code from my forked repository

git,laravel,repository,laravel-5,composer-php
I made a fork from a repository called "chrisbjr/api-guard". the repository latest version is v2.2.2, and I made a release v2.2.3 from my fork. I have my own branch which is dev-fulluth, to get the code from my fork not from the main repo, composer has to contain the below...

How to override others dependencies in composer.json

php,symfony2,composer-php,symfony-2.6
I'm using AliceFixturesBundles and this depends on NelmioAlice and Faker. Dependencies are handled internal as for example: https://github.com/h4cc/AliceFixturesBundle/blob/master/composer.json { "name": "h4cc/alice-fixtures-bundle", "description": "Symfony2 Bundle for loading fixture data with the Alice library.", "keywords": ["Symfony2", "Fixtures", "Alice", "Loader", "Doctrine", "ORM", "MongoDB"], "type": "symfony-bundle", "license": "MIT", "authors": [ { "name": "Julius Beckmann",...

Minimum stability issue

composer-php
I want to install neitanod/forceutf8 via composer and I get error: Could not find package require at any version for your minimum-stability (dev). Check the package spelling or your minimum-stability. That's the second time it does that - previously with html2text. How to fix it? Edit: My composer.json: { "name":...

How to provide username and password for composer install?

php,bash,vagrant,composer-php
I am installing a composer project with: php composer.phar install Part way through it prompts for my GitHub username and password for access due to API hits. How can input my username and password when I run the command from a bash script? The bash script is a vagrant provisioner....

Laravel Collection installation with Composer and Laravel 5

laravel,composer-php,laravel-collection
I need help with a problem. I'm learning Laravel 5. And I've found a problem trying to do something. I tried to install Laravel Collection. I go to composer.json and I add this line on require: "laravelcollective/html": "5.1.*" But when I execute composer update on shell, I have an error:...

How does Composer know what MediaWiki extensions to load?

composer-php,mediawiki,semantic-mediawiki
We've switched from using Semantic Bundle to install extensions by using Composer. Now we can skip, for some extensions, manually including entry points at the LocalSettings.php file (http://www.bn2vs.com/blog/2013/11/24/introduction-to-composer-for-mediawiki-developers). But how does MediaWiki know which extensions to load. Does it read composer.json?

Behat fails runing after updating dependencies

php,composer-php,behat
Just updated composer on a functioning Behat, and now getting the following messages open running behat. PHP Deprecated: "Symfony\Component\Console\Helper\DialogHelper" is deprecated since version 2.5 and will be removed in 3.0. Im using Behat-3 ([email protected]). Any advice will be appreciated :)...

Deleting migrations results in an Exception

php,laravel,laravel-5,composer-php,autoload
In my Application, when I run php artisan migrate:make create_location_user_table, then delete the generated file (doesn't matter if I delete the line created in vendor/composer/autoload_classmap.php, the php artisan migrate:refresh command throws an error: include(<path_to_project>/database/migrations/2015_06_21_105357_create_location_user_table.php): failed to open stream: No such file or directory After running commands to get rid of...

Composer autoload psr-0 doesn't find class

php,composer-php
This is my project structure api | PicoApi | managers | ApiManager.php composer.json index.php This is how my composer looks like: { "autoload": { "psr-0": { "PicoApi\\": "", "PicoApi\\Managers\\" : "managers" } } } This is my index.php: //require Pico Api autoload require 'vendor/autoload.php'; use PicoApi\Managers\ApiManager; try { //initialize the...

Beginner trouble understanding composer and frameworks

php,composer-php
im having a really big problem understanding the usage of composer and frameworks. The tutorials i have seen use some kind of online-editor so they dont really help me. I learned about OOP etc and now i want to do the next step and learn about frameworks and composer. I...

Composer scripts

package,laravel-5,composer-php
I'm currently developing a package for Laravel 5. Now I wrote an artisan command and I want it to run every time a user installs the package (requires) or runs composer update. So in my composer.json file of the package I have added the scripts section but for some reason...

How to to install the ircmaxell/password-compat library via Composer

symfony2,installation,composer-php,bcrypt
I'm using Symfony2 and I'm working on a login page. I want ot use the bcrypt algorithm, but to do so, I need to install the ircmaxell/password-compat library via Composer. I looked up a couple of site, but I don't understand ANYTHING! I tried reading the Symfony documentation and it...

Composer: Package that extends another from a fork

git,dependencies,fork,composer-php
I've the following situation: There is package author/package1 on GitHub and Packagist. I decided to fork it into tcb13/package1 to add some code (that will eventually get merged into the original project, however it will take time). Later on, I developed another package, tcb13/package1-extension that extends the fork tcb13/package1 by...

Cross system composer package installing

composer-php
I have a linux web server with set of different users who have specific access to different virtual hosts. All of these users belongs to one common group “www-data” ( apache ) and I want each of theses users be able to use the packages installed by composer. Sort of...

Composer: Require a package with custom namespace

php,composer-php,alias
I've been progressively starting to use Composer on my PHP projects, however there's something that I always questioned. For instance, let's say this is my composer.json file: { "require": { "ramsey/uuid": "~2.8" } } I'm telling composer I want the package ramsey/uuid and as expected it download and includes the...

drush failing with autoload.php failed to open stream

php,drupal,composer-php
I searched the whole drupal directory but I didn't find the autoload.php file. I see the error when enabling modules using drush on the command line. Here is the exact error include(sites/all/modules/contrib/guzzle/vendor/autoload.php): failed to open stream: No such file or directory composer_autoload.module:24 [warning] include(): Failed opening 'sites/all/modules/contrib/guzzle/vendor/autoload.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')...

Load git repo with composer - autoloading issue

php,git,composer-php,autoloader
I have a github repository https://github.com/KoulSlou/UPS and I would like to add it to my project. In project root I created composer.json file and defined the following autoloading properties: { "autoload": { "files": [ "libraries/Ups/Ups.php", "libraries/Ups/Ups_Base.php", "libraries/Ups/Ups_Base_Response.php", "libraries/Ups/Ups_Live_Rates.php" ] } } When I run php composer.phar install repository is being...

Capistrano Symfony Deploy Failed

php,symfony2,capistrano,composer-php
I use following configuration for my staging server, I configured this before 2 weeks that was working without any problems. Today I executed and boom it crashed with no detailed explanation about fail point. I have no idea what is going on here. Capfile # Load DSL and set up...

“PHP Composer” compared with “Ruby Gems and Bundler”

php,ruby,gem,composer-php,bundler
(As first, this question is not "which is better" question. I just want to know how they are similar and differ in functionality perspective.) I'm php developer and currently learning ruby. In these days, many php developers are encouraged to use Composer for dependency management. Before asking questions, I would...

PHPunit no tests execute on Travis CI

php,phpunit,composer-php,travis-ci
I'm been following a PHPUnit tutorial for the first time and my tests run fine locally. However, when running my tests on Travis CI, no tests are executed and my build exits with 0. My directory structure and full code can be seen on the repo. Build log from Travis...

Composer dump-autoload gives preg_match error

php,composer-php,autoload
I have Composer in my PHP project installed, and want to use the autoloader. On this page I read how the composer.json file should look like and that I should run the command dump-autoload. My composer.json file looks as follows { "require-dev":{ "phpunit/phpunit":"4.5.*", "autoload":{ "psr-0":{ "Yii\\":"yii-1.1.14.f0fee9/" } } } }...

Travis-CI fails to install composer deps

php,composer-php,travis-ci
Travis-CI start to fail on installing composer deps with next error: [InvalidArgumentException] Package ext-ssh2-0.12.0.0 must have a source or dist specified https://travis-ci.org/deployphp/deployer/jobs/62059967 Here is composer.json. Locally everything good. Why Travis-CI fails?...

How to resolve composer requirements conflicts?

composer-php,laravel-5,illuminate-container
I'm testing Laravel Framework new 5.1 version. And I want to install famous barryvdh/laravel-ide-helper package. A know that the problem is: barryvdh/laravel-ide-helper require illuminate/filesystem: 5.0.x and laravel/framework require illuminate/filesystem: 5.1.x. How can configure my composer.json file? Note: I have "minimum-stability": "dev" and "prefer-stable": true in my composer.json file. On installing,...

Exclude a package from updating in composer

composer-php
Whenever I try to add a new package using composer like "composer require packagename/package" or use "composer.phar update", I am getting all the installed packages updated. Is there any option in composer to exclude some package that I don't need to get updated?

Composer Symfony 2.5 update not updating directory structure

php,symfony2,composer-php
I followed this tutorial: https://gist.github.com/nicwortel/0c938aa77c5bd4fde064 I've added the following line in my composer.json, but it's not asking me to upgrade my directory structure. What's going wrong? (The script is present in my vendor directory) "post-update-cmd": [ "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::defineDirectoryStructure", ] I runned php composer.phar update, but composer didn't ask me to update...

Bug in vendor downloaded via composer [closed]

php,composer-php
I downloaded some dependencies and there is error in vendor. Where should I fix that error? It's bug in transformation from plural to single. Here's the code I edited in vendor. 'sses' => 'ss', // address 'shes' => 'sh', // switch 'lves' => 'lf', // half 'ses' => 's', //...

Unable to find remote helper for 'git+https'

git,composer-php
I get this error every time I try to use the composer-asset-plugin from composer. I have read already every single question here related to this problem, but none of those helped. I have curl, zlib and expat installed and I'm using the prebuilt git from my distro (Debian 8), which...

Should the vendor folder be in source control?

php,composer-php
For instance, files like /vendor/composer/classLoader.php /vendor/composer/autoload_classmap.php On a project I'm on these are checked in. I wasn't sure whether that's good practice or not, as I remember reading Laravel recommends /vendor to be in .gitignore....

Composer not composing - saying file not found

php,composer-php,psr-4
I'm using the excellent phpwkhtmltopdf library and want to update to latest version and for this I need to use composer. File structure: vendor --mikehaertl --php-shellcommand --php-tmpfile autoload.php Composer.json file: { "name": "mikehaertl/phpwkhtmltopdf", "description": "A slim PHP wrapper around wkhtmltopdf with an easy to use and clean OOP interface", "keywords":...

Laravel installation via composer

php,laravel,composer-php,laravel-5
When I try and run the following (Mac OS X Yosemite): ↦ composer global require "laravel/installer=~1.1" I get the following error: Changed current directory to /Users/USER/.composer ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set...

PSR 4 autoload not finding class

php,composer-php,psr-4
I'm not sure why my PSR-4 auotloader isn't working. My composer.json file is simply { "require" : { "abraham/twitteroauth" : "*" }, "autoload" : { "psr-4" : {"Filters\\" : "src"} } } My PHP file, which is located in src/Filters namespace Filters; class BlogFilter { public function __construct() { return...

Many DLLs missing when installing composer (windows)

php,windows,apache,composer-php
I'm trying to install composer on my computer but I get many errors about missing some DLLs. I've downloaded some of them but I cannot find any website, where to download libsybcomn64.dll. However, I don't think downloading each DLL from internet is a good solution. I'm using Windows 7 x64...

Deploying laravel 5 with AWS EB cli: UnexpectedValueException - Invalid version string

amazon-web-services,deployment,composer-php,laravel-5
So I was just about to deploy some changes for the first time in some months, and I get this error back: [UnexpectedValueException] Could not parse version constraint ^1.2.2: Invalid version string "^1.2.2" After some digging, I found the line in my composer.lock file: { "_readme": [ ... ], "hash":...

One shared vendor with two projects

php,symfony2,composer-php,autoload,vendor
I'm working on 2 applications right now. The first one is a CMS, and the second is a shop. I want to move my vendor one level above and the share it between projects. So my structure will be something like this: project1/ project2/ shared_vendor/ I read about this. I...

Installing PHP Github project on localhost using composer

php,github,localhost,composer-php
I downloaded the Text-Statistics ZIP master from Github and extracted and renamed the folder to stats on /Library/WebServer/Documents/stats. Then I used cd /Library/WebServer/Documents/stats and composer update and all dependencies built on /Library/WebServer/Documents/stats as well. When I go to http://localhost/stats/ in my browser, it shows as follows: This is my first...

Where to find composer's global packages?

php,sublimetext2,composer-php,sublimetext
For a plugin for Sublime Text I was required to install a composer package globally. In order to do this I had to run the following command: composer global require "asm89/twig-lint" "@stable" The installation started running and a few seconds later the package was installed. Voila! Well, not really. Step...

Include libraries with Composer, NPM or Bower

php,npm,composer-php,gulp,bower
I have been getting into Composer, NPM and Bower recently. I no there's a lot of overlap between their capabilities and I was wondering if my approach is sane? If not, what should I do? I typically start my PHP projects by setting up composer to load my PHP libraries...

using composer to require file shared by multiple sub-directories

php,json,parse.com,composer-php
I have a GoDaddy shared hosting site. The root folder is html I use this as a testing server so html has several sub-directories like /site1, /site2, /site3. I'd like to install and use the parse.com PHP SDK and am following this guide to set it up I have installed...

How to recover destroyed laravel project with composer

php,json,laravel-4,composer-php,alerts
I am using laravel 4.2. Today I had to reinstall one of my plugins, and now all my project has been destroyed. here's my composer.json file : { "name": "laravel/laravel", "description": "The Laravel Framework.", "keywords": ["framework", "laravel"], "license": "MIT", "type": "project", "require": { "laravel/framework": "4.2.*", "barryvdh/laravel-debugbar": "~1.8", "mews/captcha": "dev-master", "prologue/alerts":...

Composer: unresolvable dependencies when installing Silex application

php,composer-php,silex
I am trying to build a Silex application, with the following requirements requirements Yaml configuration Doctrine ORM Simple User Authorisation my composer.json { "require": { "silex/silex": "~1.2", "symfony/yaml": "2.6.7", "doctrine/dbal": "~2.2", "deralex/yaml-config-service-provider": "1.0.x-dev", "dflydev/doctrine-orm-service-provider": "[email protected]", "jasongrimes/silex-simpleuser": "~1.0" } } When I run composer update, I get the following output Loading...

Error: Class 'Stripe' not found

php,composer-php,bolt-cms
I'm trying to use the Stripe php api in a Bolt extension but it's having trouble finding the class. I added the Stripe library to composer.json: "require": { "stripe/stripe-php": "1.*" } And ran composer install. myextension/vendor/composer/autoload_classmap.php now shows the classes loaded: $vendorDir = dirname(dirname(__FILE__)); return array( 'Stripe' => $vendorDir ....

Can't install Composer on Ubuntu behind proxy

php,ubuntu,proxy,composer-php
I'm trying to install Composer, in order to use Laravel, but I'm behind the company proxy. The proxy is already configured in the system, so wget --proxy-user=<my_user_name> --proxy-password=<my_password> https://getcomposer.org/installer works (curl doesn't!), and I get the 270kB "installer" file. Next, I'm trying to run php installer as the manual says,...

Composer file is set up wrong? Not Auto loading my class - PHP

php,composer-php,autoload
In the above image you can see my composer.json. This file belongs to Freya/Loader/Assets, which you can see is expanded. You can also see the vendor directory is created and that I have a phpunit.xml file which looks as such: <phpunit bootstrap="bootstrap.php" backupGlobals="false" colors="true" convertErrorsToExceptions="true" convertNoticesToExceptions="true" convertWarningsToExceptions="true" > <testsuites>...

Composer install crashing on Laravel 5 (production only)

php,laravel,composer-php,laravel-5,dev-to-production
I have a very weird issue since yesterday. Running composer install on my production server causes this error... Keep in mind I do not get any error on my local server (Homestead VM). Nothing to install or update Writing lock file Generating autoload files Executing command (CWD): php artisan clear-compiled...

PHP Composer: Setting dynamic variable paths in the autoload function

php,composer-php,autoload
I have recently started using composer to autoload my classes. But I find I have to upload each directory individually as I store an src/ directory and a tests/ directory foreach class. For example: "Core\\Router\\": "system/Core/Router/src/", "Core\\Router\\Tests\\": "system/Core/Router/tests/", "Core\\DatabaseManager\\": "system/Core/DatabaseManager/src/", "Core\\DatabaseManager\\Tests\\": "system/Core/DatabaseManager/tests/" Is there a way to make it so...

Installing Sylius with eZ Publish 5

symfony2,doctrine,composer-php,sylius,ezpublish
I have problems installing Sylius Bundle. Here is the error when i try to access the web site or when i try to update composer : [RuntimeException] "Cannot find Doctrine RTEL" Here is my config : composer.json "doctrine/orm": "~2.3", "friendsofsymfony/user-bundle": "[email protected]", "sylius/money-bundle": "0.12", "sylius/order-bundle": "0.12", "sylius/product-bundle": "0.12", "sylius/resource-bundle": "0.12", "sylius/cart-bundle":...

Slow response from getcomposer.org breaking deployments

composer-php
It seems that getcomposer.org is responding very slowly today. This is breaking deployments that have reasonable timeouts for various steps. Is there a fallback or alternate address?

composer create-project - command donot work

composer-php,packagist
I have my project on github containing composer.json in the root directory. This is how my composer.json code looks like: { "name": "vendor/projectname", "description": "My first Composer project", "authors": [ { "name": "John Deo", "email": "[email protected]" } ], "prefer-stable": true, "minimum-stability": "dev", "require": { "php": "~5.3" } } I had...

Presta Sitemap Bundle Install Error

php,xml,symfony2,composer-php,sitemap
I have followed the presta sitemap bundle documentation and I am still having issues. I have this line in my composer.json file: "presta/sitemap-bundle": "dev-master" But I get this error: A typo in the package name The package is not available in a stable-enough version according to your minimum-stability setting On...

Laravel 5 app on Bluemix

php,laravel,composer-php,bluemix
I’ve been having trouble to deploy my laravel app to bluemix using laravel 4.2 and 5.0. This is the error in the blumix logs: 2015-05-01T16:52:49.71+0100 [STG/0] ERR [UnexpectedValueException] 2015-05-01T16:52:49.71+0100 [STG/0] ERR Could not parse version constraint ^1.2.2: Invalid version string “^1.2.2″ 2015-05-01T16:52:49.71+0100 [STG/0] ERR install [–prefer-source] [–prefer-dist] [–dry-run] [–dev] [–no-dev]...

How to install CakePHP plugins from Composer into app/Plugin

php,cakephp,plugins,cakephp-2.0,composer-php
I'm trying to install this plugin: https://github.com/ichikaway/cakephp-mongodb/ into my CakePHP project using Composer. And everything was smooth, but it installed into [project root]/Plugin (directory created by Composer I guess) instead of [project root]/app/Plugin. Obviously, in that case, it's impossible to load it by using: <?php //app/Config/bootstrap.php CakePlugin::load('Mongodb'); If I manually...

Trouble with Composer Autoloading: not loading all files

php,composer-php
I've been building a web app of my own for a while now, but have completely hit against the wall with a fatal error in PHP. Short story: I'm working on the login / user section of the project. login.php handles the login stuff, while student.php handles the account stuff....

`with_dict expects a dict` - Ansible global composer and kosssi.composer

php,composer-php,ansible,kosssi-composer
I'm trying to use the kosssi.composer Ansible role to install a global composer instance as well as a couple of composer packages. --- - hosts: myhosts remote_user: vagrant sudo: true roles: - { role: kosssi.composer, composer_path_env: true, composer_home_path: /opt/composer, composer_home_owner: vagrant, composer_home_group: vagrant, composer_global_packages: phpunit/phpunit: [email protected]' phing/phing: [email protected]' } I've...

Using Composer to Install My Own Application

php,json,composer-php
Is there a way to get composer to download my application into my root folder? I'd like users to be able to run the following in their docroot: composer require name/package And have that download all my application files to the docroot, then install dependencies into vendor via the composer.json...

Composer Package Error

github,package,composer-php,versioning,gravatar
I'm not sure what I've done wrong here. I've created a package and I'm trying to require it by using this: composer require "karl-ballard/gravatar" : "1.0.*" However, I keep getting this as an output: InvalidArgumentException Could not find package 1.0.* at any version for your minimum-stability (stable). Check the package...

PHP PHARs with composer?

php,composer-php,phar
I've been thinking of advantages and disadvantages of distributing my app as a single PHAR. I'd still like to use Composer to manage all the random dependencies I have, though. This means writing back to the phar if stuff changes, which I understand is at best a convoluted process. What's...

Downgrade Doctrine ORm 2.5 to 2.4

php,doctrine2,composer-php
i want Downgrade Doctrine Orm 2.5 to 2.4 For solve this Error : syntax error, unexpected '[', expecting ')' Note : My php Version : 5.3 (Doctrine 2.5 needed to php 5.4 and later version) And write this Code in Composer.json file : { "require": { "doctrine/common": "2.4.*", "doctrine/dbal": "2.4.*",...

Running Composer with MAMP: Unable to load dynamic library mcrypt.so

php,composer-php,mamp,mcrypt
I am attempting to get composer running on my Mac and using MAMP. I installed composer using sudo curl -sS https://getcomposer.org/installer | phpmamp So, in .bash_profile, I've added the following alias alias phpmamp='/Applications/MAMP/bin/php/php5.5.14/bin/php' After installing, I also moved composer.phar to /usr/local/bin/composer Now I try to run composer and I get...

Deploy bitbucket public repo as application dependancy through composer on Heroku

git,heroku,composer-php,bitbucket
My application's dependencies are managed using composer, and one of dependency is from bitbucket public repo. Which is working fine locally, but when I deploy it to Heroku its not resolved and even not getting any error. My composer.json is: "repositories": [ { "type": "vcs", "url": "[email protected]:vendor/repo.git" } ], "require":...

Laravel Production issue - Updating composer with Laravel 4.1.x

php,laravel,composer-php
I haven't encountered any issue in deploying my laravel project until now. I've been deploying for like almost a year already for this project. But some new bug came up. First of all. I can't run composer update, cause it says this error. composer update Warning: This development build of...

Updating project version: Composer

git,version,composer-php
What's the right way to change version number when using composer? Consider the current scenario: You have master and develop branches and your version is 1.0.0. A critical bug appears and you have to create a hotfix-1.0.1 branch (from master) to fix it and merge back to both master and...

Php use a class in the constructor of another class and require it with namespace

php,oop,composer-php
I have som legacy code that broke after an update of a dependency class of my ex colleague's Handler class of the Cosenary Instagram Class using composer. The former reference to include the class in the handler class was this: namespace Acme\Instagram; class Handler { /* GOT SOME USEFUL VARS...

Composer update/create-project/install - HTTP Request failed

php,composer-php
Recently I learned about Laravel 4.2. Then I switched to Laravel 5. All the time I've used composer to add another dependencies and stuff, I had no problems at all. Last Thursday I've created a new project using composer create-project laravel/laravel dir_name --prefer-dist. All went ok. But since Friday, I...

PHP Autoloader doesn't work on Ubuntu production server

php,ubuntu,composer-php
I have to environments i'm working developing my API (PHP based): Local development: Mac OS Yosemite - running PHP 5.5.20 Production server: Ubuntu server - running PHP 5.5.9 My code uses composer for auto loading as followed: { "require": { "facebook/php-sdk": "@stable", "everyman/neo4jphp": "dev-master", "predis/predis": "1.0.1", "aws/aws-sdk-php": "2.*" }, "autoload":...

Installing PHP Project Dependencies with Composer

php,xampp,composer-php,nette
I am trying to install Nette2.3.1 using Composer (on XAMPP). In c:\x\php folder I run this command: composer create-project nette/sandbox myprojectname When I do this, getting following error: [Seld\JsonLint\ParsingException] "c:\x\php\php.exe" does not contain valid JSON Parse error on line 1: MZÉ ♥ ♦    ╕ ^ Expected one of: 'STRING',...

Laravel 4 - Class 'Stripe' not found

laravel,composer-php
I'm trying to install Stripe into my project but I'm having issues. I'm getting the error Class 'Stripe' not found I used composer require stripe/stripe-php and everything installed fine, but I'm still having issues. This is the line that is causing the problem: Stripe::setApiKey(Config::get('stripe.secret_key')); This is my composer.json file: {...

Laravel + git, contributers have different enviroment

php,git,laravel,dependencies,composer-php
Me and my coworker are trying to use local git repo for our Laravel project. I am using Ubuntu, with PHP 5.5.9-1ubuntu4.9, and he is using Debian with PHP 5.4.39. When I pulled his commited version, I get an error when trying to run composer update: [email protected]:/var/www/frontend$ composer install Loading...

PHPExcel cannot load spreadsheet with formula

php,composer-php,phpexcel,import-from-excel
When trying to create a reader for a file, I get some strange errors. I was using the dev-master branch, then switched to 1.8.1 but that didn't seem to make any difference therefore I'm thinking it's the spreadsheet that's the problem. There are quite a lot of formulas used in...

Composer package not found in private repository

git,composer-php
I'm using Composer to load my private remote repository from BitBucket: { "require": { "pico/pico-core": "dev-dev" }, "repositories": [ { "type": "git", "url": "https:[email protected]/picodevelopmentteam/php-server-core.git" } ], "autoload": { "psr-0": { "PicoApi\\": "" } }, "minimum-stability": "dev" } My pico-core composer.json looks like this: { "name": "pico/pico-core", "require": { "facebook/php-sdk": "@stable",...

PHP Composer Autoloader Simple Structure

php,composer-php,autoloader,psr-4
I have Composer working and I'd like to use its autoloader to load my classes, but it's not working. Here's my directory structure. I'm keeping it really simple to start with. index.php composer.json Vendor controllers/webgl.php Inside webgl.php I have: namespace controllers; class webgl { public function lesson1() { } }...

symfony and Travis build composer error

php,symfony2,composer-php
Maybe you can help me, I'm trying to set up Travic-ci account, but on the build I get errors when composer install: Generating autoload files Updating the "app/config/parameters.yml" file [Symfony\Component\DependencyInjection\Exception\ParameterCircularReferenceException] Circular reference detected for parameter "database_driver" ("database_driver" > "database_driver"). Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache handling the post-install-cmd event terminated with an exception [RuntimeException]...

How can I use the new directory structure with Symfony >=2.7?

symfony2,composer-php
Before Symfony 2.7 setting the environment variable SENSIOLABS_ENABLE_NEW_DIRECTORY_STRUCTURE will trigger the prompt Would you like to use Symfony 3 directory structure? Starting from 2.7 (released yesterday) this doesn't work anymore: composer create-project symfony/framework-standard-edition symfony "2.7.*" Any idea why? I've found a use-new-directory-structure shell arg in composer script handler, how do...

Composer + Rocketeer + ZF2- Cannot install Rocketeer due to requirements conflict

php,zend-framework2,composer-php,rocketeer
Can somebody can tell me how to fix this? Rocketeer installs just fine in empty dir, but not along with my existing project, don't know w why. What is requiering that installation? - Installation request for symfony/console == 2.6.6.0 -> satisfiable by symfony/console[v2.6.6]. composer.json { "name": "zendframework/skeleton-application", "description": "Skeleton Application...

Composer - class not found after autoloading

php,composer-php
my class structure is as followed: myproject | -------src (namespace PicoCore;) | -----objects (namespace PicoCore\Objects;) -----tests (namespace PicoCore\Tests;) I've created composer.json from autoloading: { "autoload": { "psr-0": { "PicoCore": "src", "PicoCore\\Objects" : "src/objects", "PicoCore\\Tests" : "src/tests" } } } I've created a testing script after installing: <?php require_once "../../vendor/autoload.php"; use...

How to install eZ Platform via composer

php,composer-php,ezpublish,ezplatform
How do you install eZ Platform? I'd like to get starting using it and I hear that the best way is to use composer. The problem for me is I've not used either before :\ Note: This is a first post to the new stackoverflow tag: ezplatform. We needed this...

WP_UnitTestCase - how to configure the include_path correctly with phpunit PHAR

wordpress,phpunit,composer-php
I'm trying to write a php unit test for my wordpress plugin and have been following the writing-wordpress-plugin-unit-tests tutorial. I've cloned the 'core.trac.wordpress.org/browser/tests/trunk/includes' locally I have installed phpunit via the PHAR mechanism as described here : https://phpunit.de/manual/current/en/installation.html#installation.requirements. I also have a composer.json configuration [14:11:04@~]$ phpunit --version PHPUnit 4.7.3 by Sebastian...

Capifony can't download composer - not following redirect

symfony2,composer-php,capifony
I'm using Capifony to deploy my Symfony2 application, but as of today it can't download composer - jenkins output: [32m--> Downloading Composer[0m * executing "sh -c 'cd /data/www/testing/s00110/releases/20150426161117 && curl -s http://getcomposer.org/installer | php'" servers: ["*domain*"] [*domain*] executing command ** [out :: *domain*] <html> ** [out :: *domain*] <head><title>302 Found</title></head>...

how to safely update way generators 3.0 package in laravel 4.2

laravel,laravel-4,package,composer-php,way-generators
i figured out too late that way generators version 3 package is not compatible with laravel version 4.2 it only work with laravel 5, now i need to switch to a previous version of the package and i do not know how to do it properly as my laravel project...

using PayWithAmazon with symfony 2 - installed with Composer

php,symfony2,amazon,composer-php,payment
I installed this package via composer: composer require amzn/login-and-pay-with-amazon-sdk-php composer update I added this to my Controller file: use PayWithAmazon\Client; ... and would like to use the Client class, provided with this package. $amazonClient = new PayWithAmazon\Client($this->amazonCredentials); The error message of the framework: ClassNotFoundException in CartController.php line 185: Attempted to...

How to best automate deployment of NPM-dependent project?

node.js,deployment,npm,composer-php,production-environment
I'm used to deploy code depending on Composer (PHP's NPM cousing), that sports .json and .lock files. The first one describes the package and your version constraints, and the second one lists exactly what was installed. Always there's a lock file and you run composer install you're sure to receive...

Guzzle without composer

php,composer-php,guzzle
I need to use sproutvideo php lib that requires Guzzle Guzzle needs composer to install and not sure if is needed to run, since in some file i found require 'vendor/autoload.php'; i never used composer and i'm on shared hosting, where i can't install it i download Guzzle from github...

Multiple apps with composer

php,deployment,frameworks,composer-php
There is a main application, let's call it APP. APP has several dependencies (including open source projects and proprietary libraries). There are multiple clients that use their own instance of APP (on different domains that I manage). Some of these clients use a slightly adjusted version of APP. I implemented...

Unable to add Laravel package Intervention Image - Requirement could not be met

php,laravel,composer-php,laravel-5,intervention
I am trying to install Intervention Image into my Laravel 5 app. Below is my require from my composer.json: "require": { "laravel/framework": "5.0.*", "laravel/cashier": "~3.0", "barryvdh/laravel-debugbar": "~2.0", "illuminate/html": "[email protected]", "intervention/image": "[email protected]" } Upon running composer update I get an error saying: Your requirements could not be resolved to an installable...

Composer require local package

php,composer-php
I've got a couple of libraries [Foo and Bar] that I'm developing in concert, but are still technically separate things. Previously I've just re-defined the autoloader to like "Foo\\": "../Foo/src", but now that I've added a Guzzle dependency to Foo, Bar flips it's lid because it's not one of its...

Composer exit batch file after finish execution

php,batch-file,composer-php
I am trying to do some automation with batch file to perform installing of laravel and then continue with moving files & folder. My batch file looks something like this: @echo off echo Installing laravel... composer create-project laravel/laravel system --prefer-dist echo Laravel installing is done... Now moving files and folder......

Composer Autoload Issue

php,class,include,composer-php,autoload
I've added composer to an existing project that uses the PHP autoload function. Now that composer autoload.php is being used I've removed my old autoload function and I'm trying to load my existing source directory via composer autoload but it isn't picking up any of my existing source classes. Everything...

ratchet HttpServer class not found

php,websocket,composer-php,ratchet
So i made a real-time chat on windows in php with websockets and every thing worked perfectly but now when i try to run the server on my vps(debian) i get this error PHP Fatal error: Class 'Ratchet\http\HttpServer' not found in /react-chat/bin/server.php on line 11 so when i look at...

How to deploy a php application without running composer at production

php,composer-php
I have a Yii 2 web application which uses Composer for its dependencies. How am I supposed to deploy this application at a production server without having to run composer? What I would like to be done is to zip the whole application directory at the development server, copy it...

Having trouble while installing composer on ubuntu

php,ubuntu,laravel,curl,composer-php
I've just installed apache, php and curl to my computer. But I think there is something wrong with cURL with Php5.6. Actually I can install composer with ignoring the warnings but I will not be able to use composer then. I get this: curl: (60) SSL certificate problem: unable to...

Install package into custom directory Composer

path,install,package,composer-php
Hey I am trying to install a package into a custom 'admin' directory using composer. Here is my JSON: { "name": "frontier/installer", "description": "The best front end engineer package around", "require": { "aheinze/cockpit": "*" }, "extra":{ "installer-paths":{ "admin": ["aheinze/cockpit"] } } } Now when I run composer install it all...

Include library without running composer dump-autoload for a Laravel 4.x project in production

php,laravel,laravel-4,dependencies,composer-php
I'm developing for a Laravel project and we've recently started working with our DevOps team to bring our WebApp up on a staging server. The DevOps team is not familiar with Laravel and is fairly averse to running command line operations on the project to get it up and running....

Why is Symfony missing dev bundles in prod environment?

php,symfony2,composer-php
My Symfony application has a few dependencies that are only required for development, testing and the like. These are defined in my composer.json in the require-dev section. Here is how I add them in AppKernel.php: class AppKernel extends Kernel { public function registerBundles() { $bundles = array( new Symfony\Bundle\FrameworkBundle\FrameworkBundle(), new...

Composer autoload file not work if set in repositories

php,cakephp,package,composer-php
i wrote the followings "repositories": [{ "type": "package", "package": { "name": "rysas/ffxiv-lodestone-php-api", "version": "dev-master", "source": { "url": "git://github.com/rysas/Final-Fantasy-XIV-Lodestone-PHP-API.git", "type": "git", "reference": "origin/master" }, "autoload": { "files": [ "vendor/rysas/ffxiv-lodestone-php-api/ffxiv-lodestone-api.php" ] } } }] After doing a composer update, my library isn't loaded, everything works fine if i do the following "repositories":...

How to install and use php-pushwoosh on Ubuntu 12.04 LTS linux OS with/without using composer?

php,ubuntu,push-notification,composer-php,pushwoosh
I'm a PHP developer by profession. I want to install and use php-pushwoosh on my system running on Ubuntu 12.04 LTS linux OS. For it I went to the link php-pushwoosh website There I come to know about I can install php-pushwoosh by using composer. "The easiest way to install...

Deploying Laravel workbench projects through composer

laravel,laravel-4,composer-php
I've created several private repos that I'm working on through Laravel 4.2's workbench feature. How do I get composer to also install/update all the git submodules in the workbench dir on the production server when it updates the vendor dir for the main project?...

Failed installation of zend-escaper with Composer

php,zend-framework,composer-php
I'm trying to install zend-escaper but I'm getting this error: This is strange as my PHP version (from phpinfo()) is 5.5.19, the message claims it is 5.3.5(!) which should satisfy the requirement anyway. My ZF version is 1.12.13 I'm using PHP Storm Can anyone help please? Thanks Tomasz...

Travis CI is not case-sensitive by default?

filesystems,phpunit,composer-php,travis-ci,case-sensitive
I have a php project that has composer dependencies which are inherently tested in the code path of my unit tests. Here's my sample code: <?php // where FooBar is a composer package but I'm purposely typing it incorrectly here use \fooBaR public function appendNameToWords(array $words, $name) { $start =...

Laravel 5 - “laravel new” command

composer-php,laravel-5
Help guys in installing Laravel 5, I'm using Windows 7 Home premium I'm using the Git bash as my terminal I run the command composer global require "laravel/installer=~1.1" And it successfully installed But when I ran laravel new blog It shows the message below: Crafting application... 'composer' is not recognized...

How to develop PHP packages in a team using composer?

php,git,composer-php
Introduction This is quite a lengthy question, the question I asked in the title is probably ambiguous and I may change this to something more suitable. A similar question has already been asked and answered here although I do not think this entirely answers the question. Synopsis I am working...

Composer Update issue Laravel 5

php,composer-php,laravel-5
When i run the update command of composer i get the following exception at the end of update process. What is the issue?...