FAQ Database Discussion Community


Bourbon family without Ruby

ruby,gulp,bower,bourbon,neat
I'm currently trying to make my company use Bourbon/Neat/Bitters/Refills, the Toughtbot front-end stack often refered as the Bourbon family. But while we use Ruby on most of our projects, we code static websites from time to time. On that kind of project, the scaffolding speed of Bitters could be very...

Meteor application not pushing to Heroku error

heroku,meteor,sass,bourbon
I built a Meteor app that uses the bourbon scss library. I tried to push my app to heroku got the following error: Errors prevented bundling: While building the application: client/styles/bullets.scss: Scss compiler error: undefined /tmp/build_52129b38b75a2e6238de86ec866d89cf/mauvsa-gala-9a1eb00877caedf4b5202f30825b1627fb75f874/client/styles/bullets.scss:1: file to import not found or unreadable: "bourbon/bourbon" Current dir: /tmp/build_52129b38b75a2e6238de86ec866d89cf/mauvsa-gala-9a1eb00877caedf4b5202f30825b1627fb75f874/client/styles/...

width-transition not working on ::after in FF

css,css3,sass,bourbon
I have this menu that I want to try some new animation with on the hover state. The problem is that the width transition doesn't seem to work in Firefox, but in Chrome, Safari and IE. I've tried with both Bourbon mixin and without, no help. Is Firefox not capable...

SASS Compiler for Bourbon

css,sass,stylesheet,bourbon
Is there another compiler besides using the Command Prompt to compile Bourbon files? Basically, I am using Koala as my SASS Compiler and I would like to try out using Bourbon with it and when I tried to import the bourbon into my SASS file and compile that file, it...

How to define bourbon and neat in grunt js file / windows 8 user?

gruntjs,bourbon,neat
I'm trying to use this code and I get error for using "loadPath" duplicated. options: { style: "compressed", sourcemap : true, loadPath: require('node-bourbon').includePaths, loadPath: require('node-neat').includePaths }, ...

Bourbon Neat — outer-container not full width of browser

css,ruby-on-rails,bourbon,neat
I have a div that I want to act as a full-width header. Basically, the title and maybe a phone number and address. The aim of this question is to make this div the full width of the browser. New to Bourbon Neat My impression is that it works with...

Bourbon Refill Navigation Menu slide up on click

javascript,jquery,css,bourbon,neat
I am using the Bourbon Refill navigation menu, and want to modify it so when a link is clicked on in small mode the menu slides back up. At the moment the menu drops down, but when a menu item is clicked the menu stays dropped down. As I am...

Simplifying SASS @include's to a loop?

loops,sass,bourbon
I have this piece of code that is the most advanced SASS code I've built so far. Now I'm wondering if it could be simplified using some sort of loop for the @includes, but I'm having a bit of a brain freeze. Is it possible to add some kind of...

reorder columns with bourbon neat (tablet, desktop)

sass,bourbon
I'm trying to make a page with "content" on the top (for mobile view) and the sidebar below. Here is my html: <section> <div class="homepage-content"></div> <div class="homepage-sidebar"></div> </section> Here is my scss using bourbon: section { @include outer-container; } .homepage-content { @include span-columns(8); @include shift(4); /* this block should be...

Where to get versions suitability sheet of neat and bourbon?

sass,rubygems,bourbon
I want so use libsass for compiling my scss (considering positive testimonials about it's speed against ruby native compiler). The compiling ends with an error, and my searching have driven me here: (my bourbon was 4.x): https://github.com/sass/libsass/issues/365. the current version of libsass cannot compile bourbon 4.x. and the issue is...

How to update bourbon neat files in my site

updates,bourbon,neat
I installed Neat prior to the most recent gem update to 1.7.1. Now I'd like to update the files in my site install, but I'm not sure how to accomplish that. gem list indicates neat (1.7.1) I tried neat install in my sass directory, but I get the message Neat...

@include outer-container not taking default defined in grid-settings

sass,bourbon,neat
So I've got my _grid-settings.css.scss defined as per the docs and in it, among some of the other default overrides is $max-width: 1200px;. Part of the contents of my override: $visual-grid: true; $visual-grid-color: green; $visual-grid-index: front; $visual-grid-opacity: 0.2; $column: 90px; $gutter: 30px; $grid-columns: 8; $max-width: 1200px; I know this is...

Why aren't the bourbon mixins working in my jekyll site?

css,sass,jekyll,github-pages,bourbon
Every time I use $ jekyll serve --watch and attempt to add a bourbon mixin to my sass file, I get an error stating that the mixin is undefined. I've checked to see if I have properly installed bourbon, and I think I have. I have verified my @includes to...

Bourbon Neat — responsive grid

html,css,ruby-on-rails,bourbon,neat
Ive looked at the examples for Bourbon Neat responsive grid. To my knowledge I'm using it correctly. Issues the <div> tags all take up their own line as if I had made them all span-columns(12) My guess is that I am not nesting the elements correctly or I should be...

How to get Bitters working in Jekyll?

gem,sass,jekyll,bourbon
I have been using Bourbon and Neat in Jekyll with no problems. I am now trying to add Bitters to the mix, but am having problems. I have installed Bitters using gem install bitters and it works in non-Jekyll projects. My _config.yml file contains gems: [bourbon, bitters, neat]. My scss...