FAQ Database Discussion Community


Is it possible to use an Anaconda Python 3 environment together with Pycharm?

python-3.x,scipy,pycharm,anaconda
My basic problem is that I want to install scipy on a Window's machine for Python 3 and use Pycharm as my development environment. The suggestion from the Scipy Documentation as well as several StackOverflow posts (Installing NumPy and SciPy on 64-bit Windows (with Pip), Trouble installing SciPy on windows,...

Pymacs Cannot Find Packages on Anaconda

python,anaconda,pymacs
I noticed Pymacs did not recognize packages that were installed through Anaconda. Note: Just discovered a solution, I will enter it as an answer....

Why is my ctypes long size 4 and not size 8 using 64 bit python?

python,ctypes,anaconda
Downstream of this I am getting an error Python int too large to convert to C long, which led me to suspect that somehow ctypes long was too small - size 4 and not 8. I tested this and it was indeed the case. Yet, I am using Python 2.7...

Why has Anaconda added my default Python paths to the specific environment's path?

python,python-2.7,anaconda
I have created an anaconda environment. When I activate the environment I can see that the environment is using a different Python version than my default Python version. This is correct. However, when I check python path within the activated environment. import sys from pprint import pprint pprint(sys.path) I can...

output_notebook() is not defined - why?

python,ipython,anaconda,bokeh
Trying Bokeh for the first time. Using the following example code from bokeh.pydata.org: from collections import OrderedDict from bokeh.charts import Scatter from bokeh.sampledata.iris import flowers output_notebook() Inside iPython (Anaconda, py 3.4, Win 7), get the following error: --------------------------------------------------------------------------- NameError Traceback (most recent call last) <ipython-input-2-c57c6fa8f51a> in <module>() ----> 1 output_notebook()...

jupyter kernels in OSX: No module named IPython

python,osx,ipython,anaconda,jupyter
Quick side note: This question is based on issue #7947 in ipython's bug tracker. The problem seems to be an issue related to either OSX, or some weird settings on my mac (maybe both). I cannot reproduce it on a fresh Ubuntu box. I am aware that the underlying problem...

cannot import scipy.signal.convolve2d

python,scipy,anaconda
I installed Anaconda and was trying to use its convolve2d method in scipy.convolve2d, but as I import that module: 'import scipy.signal.convolve2d' ImportError Traceback (most recent call last) <ipython-input-4-e2463eecf22b> in <module>() ----> 1 import scipy.signal.convolve2d ImportError: No module named convolve2d which really confuses me. I have just installed the latest Anaconda...

how to install packages from pypi to anaconda?

python,installation,packages,anaconda,pypi
I've been using Anaconda in Window for all my python coding. I've got a few questions: How do I check all the existing packages/modules I've installed? What commands do I need to type? How do I install third-party packages, especially those available in pypi? Sometimes when I download some packages...

Pyscopg2 binary install into windows anaconda environment

python,psycopg2,anaconda
I am trying to install the psycopg2 package using the windows binary installer (for several reasons I need to use the binary installer) on a stand alone Windows 7 machine. I can successfully install the package into the root environment but cannot see it in my Anacaonda virtual environment. Is...

Vim crashes when used with Conda Python3 on Windows 7

python,windows,vim,anaconda,conda
I'm trying to have Python27 and Python34 support for the compiled 64bit version of VIM (used MSVS 2013 to compile it) on my Windows 7 machine (64bit too). I'm using Conda 64bit Python distribution where Python27 is the main installation (I also have it in my Windows PATH) and Python34...

python import shares common values?

python,python-3.x,anaconda,spyder
Might sound beginner-ish, but here goes. I am importing a Typedef script which contains variables which are used and called throughout my program. I do this by simply calling 'import Typedef' on all scripts within the package/workspace. Now I change a variable in Typedef in one of the scripts by...

Can I use Anaconda on TextMate

osx,python-3.x,textmate,anaconda
I have installed Anaconda with Python 3.4. How can I use that version on TextMate? I tried adding ~/anaconda/bin at the beginning of the PATH variable, but it doesn't work. When I try to run a program I get Program exited with code #1 after 0.00 seconds and no output....

Installing packages with pip with multiple python installs

python,windows,pip,anaconda
I have been using Anaconda python on Windows 7, but a package I need isn't supported by Anaconda python, so I installed CPython from python.org. I'd like to install the package to CPython, but pip still installs everything to C:\Anaconda\ ...\site-packages. How can I change this?

Need help to resolve issue with Anaconda Python 2.7 x32

python,python-2.7,anaconda,pythoncom
I've installed Anakonda Python 2.7 x32 package and now can't use native pythoncom-library. Full list of installed 3rd party libraries: PySide ftputil ruamel.yaml/PyYAML PyPDF simplejson PyInstaller sqlparse Padding wmi Error details here: File "X:\app\src\utils\hardware_info.py", line 2, in <module> import pythoncom File "C:\Anaconda32\lib\site-packages\pythoncom.py", line 2, in <module> import pywintypes File "C:\Anaconda32\lib\site-packages\win32\lib\pywintypes.py",...

Error in creating LMDB database file in Python for Caffe

python,numpy,anaconda,caffe,lmdb
I'm trying to create an LMDB data base file in Python to be used with Caffe according to this tutorial. The commands import numpy as np and import caffe run perfectly fine. However, when I try to run import lmdb and import deepdish as dd, I'm getting the following errors:...

How to change default Anaconda python environment

python,python-2.7,python-3.x,environment,anaconda
I've installed Anaconda and created two extra environments: py3k (which holds Python 3.3) and py34 (which holds Python 3.4). Besides those, I have a default environment named 'root' which the Anaconda installer created by default and which holds Python 2.7. This last one is the default, whenever I launch 'ipython'...

Cannot import caffe into python, libjpeg.so.62 not found

python,linux,anaconda,caffe
I cannot import caffe into (anaconda-) python. I'm following a notebook example on "logistic regression on non-image HDF5 data". When I execute the line import caffe I get the following error: --------------------------------------------------------------------------- ImportError Traceback (most recent call last) <ipython-input-17-3524921938b5> in <module>() 8 sys.path.insert(0, caffe_root + 'python') 9 ---> 10 import...

Why I can't use matplotlib.pyplot in Spyder?

python,pandas,anaconda
I'm taking an online course. In the exercise I have to plot two histogram comparing rain vs no rain ridership, here is the code I used in online course. import numpy as np import pandas import matplotlib.pyplot as plt def entries_histogram(turnstile_weather): plt.figure() ax = turnstile_weather['ENTRIESn_hourly'][turnstile_weather['rain'] == 0].plot(kind = 'hist', title...

Setup Spyder to work with Anaconda python on Ubuntu 14.04

python,python-2.7,anaconda,spyder
I installed Spyder IDE before I have installed the Anaconda (on Ubuntu 14.04), on the terminal when I type python I have the anaconda python and I can import all of its packages. But on Spyder I still have the original python and I cannot import the Anaconda packages, how...

Anaconda python not available from sudo

python,linux,sudo,anaconda
I installed Anaconda in a Google Cloud Compute environment and can use it successfully from the shell as a normal user: [email protected]:~$ python Python 2.7.9 |Anaconda 2.2.0 (64-bit)| (default, Mar 9 2015, 16:20:48) [GCC 4.4.7 20120313 (Red Hat 4.4.7-1)] on linux2 Type "help", "copyright", "credits" or "license" for more information....

How to change Python version to 2.7.8 on Anaconda distribution?

python,python-2.7,anaconda
I have some code that requires python 2.7.8. I was using the Anaconda Python distribution, which installed 2.7.6. I'm running Yosemite OSX 10.10.2. vt102:bin steigler$ conda info Current conda install: platform : osx-64 conda version : 3.4.1 python version : 2.7.6.final.0 root environment : /Users/slater/anaconda (writable) default environment : /Users/slater/anaconda...

What happens to my scipy.sparse.linalg.eigs?

python,scipy,sparse-matrix,anaconda
I use python 2.7.8 with the Anaconda distribution and I have problems with scipy. Let A be a sparse matrix; I want to calculate its eigenvalues but if I write: import scipy scipy.sparse.linalg.eigs(A) I get the error Traceback (most recent call last): File "<stdin>", line 1, in <module> TypeError: 'module'...

What are the differences between Conda and Anaconda

python,anaconda,conda
I first installed Anaconda on my ubuntu at ~/anaconda, when I was trying to update my anaconda, according to the documentation from Continuum Analytics, I should use the following commands: conda update conda conda update anaconda Then I realized that I did not have conda installed, so I installed it...

How to install vtk with gl2ps enabled using conda

python,compilation,vtk,anaconda,conda
I am using anaconda, and I've built vtk with conda using conda install vtk The default build of vtk is without gl2ps, and I want to know how can I build (or rather rebuild) vtk with gl2ps enabled using conda. I am actually tring to execture this example code: from...

how to specify external software requirements with conda/meta.yaml in Python?

python,travis-ci,anaconda,conda
I am writing a meta.yaml file for a python package to be used in conda packages in a way that works with CI systems. how can i specify external software requirements for the package? meaning software that is not a python library but is required for the package unit tests...

install issue with python - spacy package in anaconda environment

python-3.x,install,nlp,anaconda,spacy
I'm attempting to follow this tutorial to install the natural language processing package spaCy into a python 3 anaconda environment, windows 8 I opened console, cd-ed to my site-packages folder, activated environment, pip-ed for install, everything seemed fine except I couldn't run the second command here $ pip install spacy...

Failed to run Python script with Conda

python,anaconda,conda,menpo
I tried to install menpo like in this tutorial. After that I installed menpofit, menpo3d and menpodetect: conda install -c menpo menpofit conda install -c menpo menpo3d conda install -c menpo menpodetect Next I ran this python script from CMD(python testPy.py): import menpo.io as mio from menpo.visualize import visualize_images images...

Trouble installing pymssql

python,anaconda,pymssql
Trying to install pymssql with an anaconda installation and keep encountering package conflicts: conda install -c https://conda.binstar.org/prometeia pymssql returns: Hint: the following combinations of packages create a conflict with the remaining packages: - python 3.4* - pymssql All packages are up to date (conda update --all) Thanks!...

Can't get knn.py to work in Python installation (Anaconda)

python-2.7,anaconda
I'm relatively new to Python and I'm currently using an Anaconda installation. When I execute the code below, I get an error that states 'ImportError: No module named knn' I've checked and I've got knn in the site-packages folder, which came with the Anaconda installation: (....site-packages/PCV/classifiers/knn) Any help on how...

When I try and run pyspark.cmd I get the error message “find: 'version': No such file or directory”

python,apache,apache-spark,anaconda
I'm trying to get started with Apache Spark. I'd like to use it via python. However, when I run pyspark from the command line I get the following error message: C:\Programs\Apache\Spark\spark-1.2.0-bin-hadoop2.4\bin>pyspark.cmd Running python with PYTHONPATH=C:\Programs\Apache\Spark\spark-1.2.0-bin-hadoop2. 4\bin\..\python\lib\py4j-0.8.2.1-src.zip;C:\Programs\Apache\Spark\spark-1.2.0-bi n-hadoop2.4\bin\..\python; Python 2.7.8 |Anaconda 2.1.0 (32-bit)| (default, Jul 2 2014, 15:13:35) [MSC v.1 500...

Anaconda site-packages

python,python-2.7,pip,anaconda
After installing a package in an anaconda environment, I'll like to make some changes to the code in that package. Where can I find the site-packages directory containing the installed packages? I do not find a directory /Users/username/anaconda/lib/python2.7/site-packages...

Resolve Anaconda/iPython Notebooks/Spyder IDE launch failure on zmq lib import?

python,ide,ipython-notebook,anaconda,spyder
This is a fresh Anaconda 2.1 install on Windows 7 - 64, python 2.7.8 . The Spyder IDE fails to launch, and throws the same error/writes same traceback when "python spyder --reset" is run from cli. Looking at the traceback, it appears to be a problem loading 'zmq' module. That...

Bad Interpreter Error Trying to Install Packages in Anaconda

python,linux,path,packages,anaconda
I'm trying to install neo into my Anaconda distribution using conda install -c https://conda.binstar.org/neuroinf neo (taken from here) but am getting the error: bash: /transform/anaconda/bin/conda: /usr/local/anaconda/bin/python: bad interpreter: No such file or directory It's not finding /usr/local/anaconda/bin/python because it doesn't exist. I have anaconda installed in /transform/anaconda/. I've edited my...

Deleted miniconda folder, python won't run

python-2.7,anaconda,miniconda
I installed/ miniconda in the following directory: /home/arturo/Documents/project1/pwd but then I deleted it by typing: rm -r pwd/ Now I can't run python anymore (from any directory). Not really sure what happened. I get this error: bash: /home/arturo/Documents/project1/pwd/bin/python: No such file or directory ...

'ls' is not recognized in Anaconda Python 2.7 Spyder

python-2.7,anaconda,spyder
I run my codes in Anaconda Spyder Python 2.7 for Windows 7 64bits. But when I run this code: !ls -lh ./training3.crfsuite I received this error: 'ls' is not recognized as an internal or external command, operable program or batch file. Does anyone know why? Thank you....

error: command 'gcc' failed with exit status 1 installing Fatiando (Python Package)

python,gcc,anaconda
I am trying to install fatiando, a geophysical modelling package for Python. I have a Mac with OS X v10.9.5. I am getting all the dependencies for Fatiando (via Anaconda) by following the recommended installation suggested on the package site. I have Xcode installed. I get a list of warnings...

plt.show() hangs on OSX with Anaconda Python

python,matplotlib,anaconda
import matplotlib.pyplot as plt plt.figure() plt.show() ...crickets. The interpreter hangs and I can't seem to interrupt it. This is with Python 2.7.9 and Anaconda 2.2.0 (x86_64) on OSX. Does this happen for anyone else? How can I solve this problem?...

how to create a .condarc file for Anaconda?

python-2.7,proxy,anaconda,conda
I am trying to set up a proxy server in Anaconda because my firewall does not allow me to run online commands such as conda update I see online that I should create a .condarc file that contains the proxy address. Unfortunately, I dont know how to create that file...

Conda virtual envinment not changing under Windows

python,windows,anaconda,conda
I have installed Anaconda 2.2.0 for Windows and created a virtual environment via: > conda create -n my-env anaconda The environment is sucessfully created and I see it in my list of envinronments (and indeed the directory is there in Anaconda\envs..) > conda info -e # conda environments: # my-env...

installing Anaconda on windows

python,python-2.7,pycharm,anaconda
Currently I have python 2.7 installed, and I decided to install Anaconda (same version). My questions are: What is the safest way to do it? Uninstall python 2.7 first? Can I move packages installed on my old python version manually (without reinstalling them again)? Should I change something in my...

symbol lookup error after updating conda 'undefined symbol: cairo_ft_font_options_substitute'

matplotlib,anaconda,conda
Last week I updated conda to version 3.11.0, after that I found either %pylab or plt.plot would encounter the symbol lookup error. [email protected]:~$ ipython In [1]: from matplotlib import pyplot as plt In [2]: plt.plot([1, 2, 3, 4]) /home/min/anaconda/bin/python: symbol lookup error: /usr/lib/i386-linux-gnu/libpangocairo-1.0.so.0: undefined symbol: cairo_ft_font_options_substitute [email protected]:~$ ipython In [1]:...

anaconda virtual env imports modules from global

python,anaconda,env
Working in Windows PowerShell, I created a virtual environment within Anaconda using >create conda -n test python=2.7.8 I activated it using >activate test activating environment "test"... The test env contains no packages. Python is the only thing in there. I checked the test\Lib\site-packages folder and it is empty. I started...

R not producing a figure in jupyter (IPython notebook)

r,windows-8,ipython-notebook,anaconda,jupyter
I am very excited about using python and R together and tried using R in Jupyter (ipython notebbok), however, I could not generate figures in the R kernel. The error message shown below is displayed when I try to plot figures. I highly appreciate your help. I am using Anaconda...

Does 64-bit Anaconda on win32 uses 32-bit or 64-bit?

python,winapi,anaconda
I guess the answer is 32-bit, but I'm a bit confused on why I can even install Anaconda 64 in a win32. I used to work on Anaconda 64-bit but I just realized that my system is win32 and this generated some exceptions from time to time. See for instance...

Plotly killed my python install

python,pip,anaconda,plotly
I just tried to install Plotly using pip. I am running python from Anaconda and now anytime I attempt to run anything python I get the following errors and I have no idea how to fix it. I am running on Windows 7 64bit, Python3,4 PS Z:\> pip Traceback (most...

How do I use a conda environment with mod_wsgi?

python,apache,mod-wsgi,anaconda,conda
My first post, and I'm new to both Python and Apache, so please go easy on me. I have a Python web application in a conda environment that serves up content just fine using Flask. Now I need to serve everything with Apache instead of Flask. I can get Apache...

Installing github version of package with Anaconda

python,git,sympy,anaconda
I have Sympy installed with Anaconda, my version (of Sympy) is 0.7.6 . I want to be able to use the git version of Sympy. Do you know how can I tell to Anaconda to substitute the 2 versions ? I've tried using the git clone command, but the Sympy...

How do I set up a virtual environment with Flask using conda?

python,flask,virtualization,anaconda,conda
I wish to set up a virtual environment that I can use to develop web applications using the Flask framework for Python (3.4.2, Mac OS). I was given the instructions on how to do that here, using the virtualenv. However, trying to follow these instructions I ran into a problem:...

Will this bash loop apt-get install all my anaconda packages?

bash,anaconda
I don't want to just try it and mess something up. $ dlpackages=$(ls -l anaconda3/bin | awk '{print $9}') $ for package in $dlpackages; do sudo apt-get install $package; done or as root: $ for package in $dlpackages; do apt-get install $package; done...

Ubuntu, Anaconda: Cannot import python shapely package

python,ubuntu,importerror,anaconda,shapely
Shapely Import problem Related to MAC OS X I installed shapely using sudo apt-get install python-shapely. I am using Python 2.7.8 |Anaconda 2.1.0 (64-bit)| with ubuntu 14.04 LTS (64 bit) After successful installation, when I try to import it from ipython it gives me an import error. ImportError: No module...

Pandas Time Index pick largest number/last number on given day

python-3.x,pandas,time-series,dataframes,anaconda
I have a Pandas DataFrame object that looks something like this: 'Thing 1': Actual Predicted Error Date 2014-09-15 140.00 0.000000 140.000000 2014-09-15 358.03 127.738344 230.291656 2014-09-16 373.04 326.672566 46.367434 2014-09-17 427.99 340.367941 87.622059 2014-09-18 484.87 390.505241 94.364759 2014-09-18 488.22 442.403505 45.816495 2014-09-18 491.57 445.460101 46.109899 2014-09-29 553.37 448.516697 104.853303 2014-09-29...

Will installing Anaconda3 change Mac OS X default Python version to 3.4?

python,python-2.7,python-3.x,anaconda
I'm planning to install Anaconda3 for Python 3.4. Since by default, Mac OS X uses Python2, will install Anaconda3 change the default Python version for the system? I don't want that to happen since Python3 can break backwards compatibility. If it does change the default Python version, how can I...