internet-explorer,dasblog , Why does IE show junk for my dasBlog blog?


Why does IE show junk for my dasBlog blog?

Question:

Tag: internet-explorer,dasblog

If I look at my blog in Chrome or Firefox, it looks as I expect. However, if I try to look at it in IE (11.0.9600.17801) it asks me if I want to download W69NUE8S (or some other random file name), which looks like some binary file.

http://dotnetwhatnot.pixata.co.uk/

I tried deleting all my temporary files, but it didn't help.

Anyone any ideas?


Answer:

The issue here appears to be the double-gzipping of the content. This is evident by the headers:

HTTP/1.1 200 OK
Cache-Control: public
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip,gzip
...

Note the doubling-up on the Content-Encoding header. According to an older Firefox bug, this issue affected not only previous versions of Firefox, but also Internet Explorer, versions 8 and up. It appears as though Mobile Safari may also affected by this to some degree.

I was able to decode the content twice via a custom FiddlerScript, and confirm that this remedies the problem in Internet Explorer, and Microsoft Edge.

I'm going to open up a ticket on this for the Networking team to consider. In the meantime, I would encourage you to dial it back a bit, and only encode your out-going content once. This will ensure that users on older Firefox versions, and Internet Explorer will be able to see your content.

If you cannot modify the compression rules, your only other option is to disable it altogether for the time being.

I have replicated this issue here: http://sampsonvideos.com/experiments/gzipgzip.php


Related:


Using getComputedStyle with IE 11


javascript,jquery,css,internet-explorer
NOTE: This has an update below. I will likely change description as it is not a getComputedStyle issue, it is an issue actually with print-media and the fact that Internet Explorer now supports document.styleSheets[].cssRules. I am a bit confused on this as I thought this worked and I am not...

Fixed position misbehaviour in IE11


css,internet-explorer,css-position,css-transitions,internet-explorer-11
I am experiencing elements position misbehaviour into my page, in IE(11) only; live link here. The logotext, the menu and the left sidebar text, remain in place doesn't move with the wrapper when the left slider is open (clicking on info+ button). I've read about position: fixed + transition in...

Call onkeyup function while doing automation


internet-explorer,powershell,automation
I am trying to perform IE automation using PowerShell. While automating some manual task using IE object, I am able to navigate to the website and enter value in text box, but the submit button available on website can only be triggered after a key up event is fired in...

Font Face issues in Internet Explorer 8


css,internet-explorer,fonts,internet-explorer-8,font-face
I created a test page for IE 8 to see if i could use Google fonts. You can find the code at the end of the question. I am including every Google font i need by using a element with a list of them. Now, depending on the HREF attribute...

In IE, anchor text is overflowing/overlapping instead of wrapping, but not other text


html,css,internet-explorer,drupal-7
I am running into an annoying problem I have yet to solve. Before I get too far into this I will point out that I am doing this in Drupal 7 (so no need to comment about the excessive wrapper elements, I already know). The problem is that in all...

How to set the IEDriverServer.exe through command line in protractor


internet-explorer,selenium,selenium-webdriver,webdriver,protractor
I would like to set the IEDriver executable path via command line while using protractor. I am using the following command, but it is not considering path to the IEDriver executable. cd > protractor --seleniumArgs "['-Dwebdriver.ie.driver=../selenium/IEDriverServer.exe']" conf.js I am getting the error: var template = new Error(this.message); ^ UnknownError: The...

How do I wrap text in a pre tag for Internet explorer?


html,css,internet-explorer,whitespace,word-wrap
I am using following code to wrap the <PRE> region in HTML: <PRE style = "white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;"> It is working fine on chrome and Mozilla but the same is not working for IE. I am using IE9. Please tell me if any...

Developers tool(F12) is opening in Internet Explorer when it is launched by watir-webdriver


internet-explorer,selenium,selenium-webdriver,watir-webdriver,developer-tools
I am automating a web application on Internet Explorer using Watir-webdriver and ruby. When I run my script in my Laptop[Win7(x64) and IE11] it is running without opening Developers Tool in Internet explorer. But When I test the same script in Virtual Machine[Win8(x64) and IE10], Intenet Exploerer browser opening with...

SSL certificate error 403.13 in IIS 7.5


internet-explorer,iis-7,ssl-certificate,sha1,http-status-code-403
I'm getting 403.13 in IIS logs, when I'm trying to access my api using the created certificate(sha1). Further I tested the same certificate in other test environment it works treat and I get the the XML from the api without any issue. Certificate pfx is installed in Certificate store and...

What is the proper way to get the value of a React