internet-explorer,dasblog , Why does IE show junk for my dasBlog blog?


Why does IE show junk for my dasBlog blog?

Question:

Tag: internet-explorer,dasblog

If I look at my blog in Chrome or Firefox, it looks as I expect. However, if I try to look at it in IE (11.0.9600.17801) it asks me if I want to download W69NUE8S (or some other random file name), which looks like some binary file.

http://dotnetwhatnot.pixata.co.uk/

I tried deleting all my temporary files, but it didn't help.

Anyone any ideas?


Answer:

The issue here appears to be the double-gzipping of the content. This is evident by the headers:

HTTP/1.1 200 OK
Cache-Control: public
Content-Type: text/html; charset=utf-8
Content-Encoding: gzip,gzip
...

Note the doubling-up on the Content-Encoding header. According to an older Firefox bug, this issue affected not only previous versions of Firefox, but also Internet Explorer, versions 8 and up. It appears as though Mobile Safari may also affected by this to some degree.

I was able to decode the content twice via a custom FiddlerScript, and confirm that this remedies the problem in Internet Explorer, and Microsoft Edge.

I'm going to open up a ticket on this for the Networking team to consider. In the meantime, I would encourage you to dial it back a bit, and only encode your out-going content once. This will ensure that users on older Firefox versions, and Internet Explorer will be able to see your content.

If you cannot modify the compression rules, your only other option is to disable it altogether for the time being.

I have replicated this issue here: http://sampsonvideos.com/experiments/gzipgzip.php


Related:


Java exception detected in safari but not detected in IE?


java,internet-explorer,nullpointerexception,safari
I have a java applet code that works fine when it's opened from IE, but if it's opened from Safari, Java console produces a nullpointerexception. The code that generate this behaviour is shown below: public class MsgBoxPanel extends JDialog { Panel panel1 = new Panel(); JLabel label1 = new JLabel();...

VBScript to detect Facebook IE window, press Like and close the window


facebook,internet-explorer,vbscript
I tryed to make a script to detect the IE window that is opened on Facebook and hit the Like button. Let's say I have 10 IE opened. Only one of them is on a page on Facebook. I want my script to detect that IE window, click this button:...

JavaScript Date not working properly in IE8 [duplicate]


javascript,google-chrome,internet-explorer
This question already has an answer here: Javascript JSON Date parse in IE7/IE8 returns NaN 6 answers Chrome showing result as expected but IE-8 giving NAN when i execute the following: Chrome: d = new Date("2014 12 01") // results Mon Dec 01 2014 00:00:00 GMT+0500 (Pakistan Standard Time)...

SSL certificate error 403.13 in IIS 7.5


internet-explorer,iis-7,ssl-certificate,sha1,http-status-code-403
I'm getting 403.13 in IIS logs, when I'm trying to access my api using the created certificate(sha1). Further I tested the same certificate in other test environment it works treat and I get the the XML from the api without any issue. Certificate pfx is installed in Certificate store and...

Fixed position misbehaviour in IE11


css,internet-explorer,css-position,css-transitions,internet-explorer-11
I am experiencing elements position misbehaviour into my page, in IE(11) only; live link here. The logotext, the menu and the left sidebar text, remain in place doesn't move with the wrapper when the left slider is open (clicking on info+ button). I've read about position: fixed + transition in...

OverCls is not working in IE11


javascript,css,internet-explorer,extjs
I am working with extjs 4.2 and need an advice to solve this small bug. I have an extjs button in my js file as: { xtype : 'button', text : 'Add Drive', padding : '10px 10px 10px 10px', overCls : 'overDrive' } and my in my css i have...

correct HTML pages won't load in IE10


javascript,jquery,html,internet-explorer,browser
I'm editing someone elses webpage for content, by changing the HTML files on the drive, adding text, comments, wtv. I'm not a web designer, so this is the only way I knew to do it. On most browsers, my changes show, but on internet explorer, sometimes it will revert to...

Inconsistent display on IE & Firefox


html,css,internet-explorer,firefox,twitter-bootstrap-3
I'm using Bootstrap on my website project. I'm through with the design but the items are displayed out of place on IE & Firefox. The same page renders great on Chrome. I used developer tools on the three browsers to make sure there was no difference in the CSS properties....

How to set the IEDriverServer.exe through command line in protractor


internet-explorer,selenium,selenium-webdriver,webdriver,protractor
I would like to set the IEDriver executable path via command line while using protractor. I am using the following command, but it is not considering path to the IEDriver executable. cd > protractor --seleniumArgs "['-Dwebdriver.ie.driver=../selenium/IEDriverServer.exe']" conf.js I am getting the error: var template = new Error(this.message); ^ UnknownError: The...

jQuery & CSS only load after many refreshes


jquery,css,html5,internet-explorer,internet-explorer-11
If you open this page in IE11, the CSS and jQuery don't load: http://javasmart.gooberdev.com/ If you refresh the page once, maybe even twice, it still doesn't load. But if you hit F5 a bunch of times in succession, the CSS and jQuery finally load and the page displays correctly. This...

HTML/CSS menu not working on IE


html,css,internet-explorer
I'm working on a website and I was happy that all was looking good on Chrome, Firefox and Safari. Then it came it suddenly in my mind, I started sweating, the heart started beating fast.. oh God, I have to test it on IE! And, of course, it doesn't work...

How to avoid wrap in IE7 when I have two ul in a navigation?


html,css,css3,internet-explorer,internet-explorer-7
In ie8 or firefox browser,My code runs well,the two ul are in the same line.But when I ie7,the two ul are in the diffrent line,How to make then in the same line in ie7? <DIV id='navigation'> <ul><li><span> leftspan </span></li></ul> <ul style='float:right;'> <li><span> leftspan </span></li> <li><a href="http://www.google.com" target="_blank">google</a></li> <li><a href="http://www.apple.com" target="_blank">apple</a></li>...

IE 10 Flexbox height bug?


html,css,internet-explorer,internet-explorer-10,flexbox
I am unable to figure out why IE10 adds extra margin's or height to the green element below. http://jsfiddle.net/q4ofmfar/ Expected style as displayed by most browsers: Incorrect style as rendered by IE10.0: http://jsfiddle.net/q4ofmfar/ HTML <div class="row"> <div id="box1"> <div> Lorem ipsum dolor sit amet, consectetur adipiscing elit. Mauris dapibus vehicula...

Internet Explorer hover/rgba/opacity/css3 compatibility


css3,internet-explorer,hover,internet-explorer-9,rgba
I am using CSS3 with an rgba alpha opacity hover to display text over an image when the user hovers. Works fine in chrome, firefox and safari but when trying in internet explorer (9) it just shows the image and hovering does nothing. Check out the code here: http://jsfiddle.net/b16pow50/ div...

Developers tool(F12) is opening in Internet Explorer when it is launched by watir-webdriver


internet-explorer,selenium,selenium-webdriver,watir-webdriver,developer-tools
I am automating a web application on Internet Explorer using Watir-webdriver and ruby. When I run my script in my Laptop[Win7(x64) and IE11] it is running without opening Developers Tool in Internet explorer. But When I test the same script in Virtual Machine[Win8(x64) and IE10], Intenet Exploerer browser opening with...

What is the proper way to get the value of a React